Bookmarks

Yahoo Gmail Google Facebook Delicious Twitter Reddit Stumpleupon Myspace Digg

Search queries

www.webdp.net, Event 9 IIS log failed to write entry, wwwxxx jeffs, Catastrophic failure Unexpected method call sequence. 0x8000ffff (-2147418113)., ksh lock a file, [unixODBC][Driver Manager]Driver's SQLAllocHandle on SQL_HANDLE_DBC failed, sed: -e expression #1, char 1: unterminated address regex, procmail + change subject, w2ksp4.exe download, /proc/kallsyms format

Links

XODOX
Impressum

#1: allowDefinition="MachineToApplication"

Posted on 2005-06-20 14:52:02 by Boonaap

I have been looking around on different sites and fora, and i have a similar
problem than some people had before...
it is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This error
can be caused by a virtual directory not being configured as an application
in IIS.

this is the solution i've read (almost everywhere)
"You need to create an application or a virtual directory ( with the IIS
Manager ) for the directory in which the code is placed."

Since I have several subfolders in my app, that would mean that I have to
make an application of every single folder?

There has to be another solution, or am I wrong ?

Report this message

#2: Re: allowDefinition="MachineToApplication"

Posted on 2005-06-20 15:19:27 by nomailreplies

re:
> Since I have several subfolders in my app, that would mean
> that I have to make an application of every single folder?

No.

It means that if you have an application, you should not configure the
MachineToApplication settings in web.config's in the subdirectories.

All you have to do is set the MachineToApplication settings in your
Application's root, and they will be inherited in the subdirectories.

Solution :

Configure all MachineToApplication settings in your application's root,
and remove all MachineToApplication settings from your application's
subdirectories.




Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Boonaap" <Boonaap@discussions.microsoft.com> wrote in message
news:50F3D147-5B7A-4A77-B495-6D3815D0386C@microsoft.com...
>I have been looking around on different sites and fora, and i have a similar
> problem than some people had before...
> it is an error to use a section registered as
> allowDefinition='MachineToApplication' beyond application level. This error
> can be caused by a virtual directory not being configured as an application
> in IIS.
>
> this is the solution i've read (almost everywhere)
> "You need to create an application or a virtual directory ( with the IIS
> Manager ) for the directory in which the code is placed."
>
> Since I have several subfolders in my app, that would mean that I have to
> make an application of every single folder?
>
> There has to be another solution, or am I wrong ?

Report this message

#3: Re: allowDefinition="MachineToApplication"

Posted on 2005-06-20 15:33:06 by Boonaap

Well in the mean time I found a workaround in the machine.config
but had a bad feeling about it, because it seems a bit risky

thx

"Juan T. Llibre" wrote:

> re:
> > Since I have several subfolders in my app, that would mean
> > that I have to make an application of every single folder?
>
> No.
>
> It means that if you have an application, you should not configure the
> MachineToApplication settings in web.config's in the subdirectories.
>
> All you have to do is set the MachineToApplication settings in your
> Application's root, and they will be inherited in the subdirectories.
>
> Solution :
>
> Configure all MachineToApplication settings in your application's root,
> and remove all MachineToApplication settings from your application's
> subdirectories.
>
>
>
>
> Juan T. Llibre
> ASP.NET MVP
> http://asp.net.do/foros/
> Foros de ASP.NET en Español
> Ven, y hablemos de ASP.NET...
> ======================
>
> "Boonaap" <Boonaap@discussions.microsoft.com> wrote in message
> news:50F3D147-5B7A-4A77-B495-6D3815D0386C@microsoft.com...
> >I have been looking around on different sites and fora, and i have a similar
> > problem than some people had before...
> > it is an error to use a section registered as
> > allowDefinition='MachineToApplication' beyond application level. This error
> > can be caused by a virtual directory not being configured as an application
> > in IIS.
> >
> > this is the solution i've read (almost everywhere)
> > "You need to create an application or a virtual directory ( with the IIS
> > Manager ) for the directory in which the code is placed."
> >
> > Since I have several subfolders in my app, that would mean that I have to
> > make an application of every single folder?
> >
> > There has to be another solution, or am I wrong ?
>
>
>

Report this message

#4: Re: allowDefinition="MachineToApplication"

Posted on 2005-06-20 16:17:03 by nomailreplies

Hi, Boonaap.

Here's the main distinctions to keep in mind :

MachineToApplication settings in machine.config are machine-wide.
They affect *all* .net applications on the machine.

You can restrict MachineToApplication settings to *one* application
by making the settings in *that* application's web.config.

MachineToApplication web.config settings in any subdirectory
not configured as an Application throw the error you encountered.




Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Boonaap" <Boonaap@discussions.microsoft.com> wrote in message
news:C3D0ACA0-391D-4904-A597-CF57D84DDB4D@microsoft.com...
> Well in the mean time I found a workaround in the machine.config
> but had a bad feeling about it, because it seems a bit risky
>
> thx
>
> "Juan T. Llibre" wrote:
>
>> re:
>> > Since I have several subfolders in my app, that would mean
>> > that I have to make an application of every single folder?
>>
>> No.
>>
>> It means that if you have an application, you should not configure the
>> MachineToApplication settings in web.config's in the subdirectories.
>>
>> All you have to do is set the MachineToApplication settings in your
>> Application's root, and they will be inherited in the subdirectories.
>>
>> Solution :
>>
>> Configure all MachineToApplication settings in your application's root,
>> and remove all MachineToApplication settings from your application's
>> subdirectories.
>>
>>
>>
>>
>> Juan T. Llibre
>> ASP.NET MVP
>> http://asp.net.do/foros/
>> Foros de ASP.NET en Español
>> Ven, y hablemos de ASP.NET...
>> ======================
>>
>> "Boonaap" <Boonaap@discussions.microsoft.com> wrote in message
>> news:50F3D147-5B7A-4A77-B495-6D3815D0386C@microsoft.com...
>> >I have been looking around on different sites and fora, and i have a similar
>> > problem than some people had before...
>> > it is an error to use a section registered as
>> > allowDefinition='MachineToApplication' beyond application level. This error
>> > can be caused by a virtual directory not being configured as an application
>> > in IIS.
>> >
>> > this is the solution i've read (almost everywhere)
>> > "You need to create an application or a virtual directory ( with the IIS
>> > Manager ) for the directory in which the code is placed."
>> >
>> > Since I have several subfolders in my app, that would mean that I have to
>> > make an application of every single folder?
>> >
>> > There has to be another solution, or am I wrong ?
>>
>>
>>

Report this message