Bookmarks

Yahoo Gmail Google Facebook Delicious Twitter Reddit Stumpleupon Myspace Digg

Search queries

w2ksp4.exe, WwwxxXdbf, procmail "FROM_MAILER" patch, Use of assignment to $[ is deprecated at /usr/local/sbin/apxs line 86. , wwwxxx vim, mysql closing table and opening table, 800c5000, setgid operation not permitted, pciehp: acpi_pciehprm on IBM, WWWXXX.DBF

Links

XODOX
Impressum

#1: Configure foreign host for PostgreSQL 8.0.3 on WindowsXP

Posted on 2005-09-28 09:33:14 by Todd Rockhold

------=_Part_862_25805662.1127892794651
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Installed PostgreSQL 8.0.3 on WindowsXP. Have not been able to configure so
that a client program running on a different WindowsXP box can connect to
the PostgreSQL database.

As I understand the documentation, at least one of the following
configurations should work, but none do. What have I done wrong and how can
I configure so that a connection can be successfully made?


1) The postgresql.conf file has (with everything else being the installatio=
n
default values):

listen_addresses =3D '*'

2) None of the following configurations of the pg_hba.conf file worked (the
program runs on 192.168.2.120 <http://192.168.2.120>):

# IPv4 local connections:
#host all all 127.0.0.1/32 <http://127.0.0.1/32> md5
host all all 192.168.2.120/24 <http://192.168.2.120/24> md5

# IPv4 local connections:
#host all all 127.0.0.1/32 <http://127.0.0.1/32> md5
host all all 192.168.2.120 <http://192.168.2.120>
255.255.255.255<http://255.255.255.255>md5

# IPv4 local connections:
host all all 127.0.0.1/32 <http://127.0.0.1/32> md5
host all all 192.168.2.120/24 <http://192.168.2.120/24> md5

# IPv4 local connections:
host all all 127.0.0.1/32 <http://127.0.0.1/32> md5
host all all 192.168.2.120 <http://192.168.2.120>
255.255.255.255<http://255.255.255.255>md5

I have a Symantec personal firewall installed which I turned off during
testing.

The program runs fine on localhost.

Am using the Npgsql .NET library. The Npgsql.Npgsql.Open() call throws an
exception, the error text of which is "System.Net.Sockets.SocketException:
NO connection could be made because the target machine actively refused it.=
"

------=_Part_862_25805662.1127892794651
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Installed PostgreSQL 8.0.3 on WindowsXP.&nbsp; Have not been able to
configure so that a client program running on a different WindowsXP box can=
connect to the PostgreSQL database. <br>
<br>
As I understand the documentation, at least one of the following configurat=
ions should
work, but none do.&nbsp; What have I done wrong and how can I
configure so that a connection can be successfully made?<br>
<br>
<br>
1) The postgresql.conf file has (with everything else being the installatio=
n default values): <br>
<br>
listen_addresses =3D '*'<br>
<br>
2) None of the following configurations of the pg_hba.conf file worked (the=
program runs on <a href=3D"http://192.168.2.120">192.168.2.120</a>):<br>
<br>
# IPv4 local connections:<br>
#host&nbsp;&nbsp;&nbsp;
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
<a href=3D"http://127.0.0.1/32">127.0.0.1/32</a>&nbsp;&nbsp;&nbsp;&nbsp;&nb=
sp;&nbsp;&nbsp;&nbsp;&nbsp; md5<br>
host&nbsp;&nbsp;&nbsp;
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
all&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
<a href=3D"http://192.168.2.120/24">192.168.2.120/24</a>&nbsp;&nbsp;&nbsp;&=
nbsp;&nbsp;&nbsp; md5<br>
<br>
# IPv4 local connections:<br>
#host&nbsp;&nbsp;&nbsp;
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
<a href=3D"http://127.0.0.1/32">127.0.0.1/32</a>&nbsp;&nbsp;&nbsp;&nbsp;&nb=
sp;&nbsp;&nbsp;&nbsp;&nbsp; md5<br>
host&nbsp;&nbsp;&nbsp;
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
all&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
<a href=3D"http://192.168.2.120">192.168.2.120</a> <a href=3D"http://255.25=
5.255.255">255.255.255.255</a> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp; md5<br>
<br>
# IPv4 local connections:<br>
host&nbsp;&nbsp;&nbsp;
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
<a href=3D"http://127.0.0.1/32">127.0.0.1/32</a>&nbsp;&nbsp;&nbsp;&nbsp;&nb=
sp;&nbsp;&nbsp;&nbsp;&nbsp; md5<br>
host&nbsp;&nbsp;&nbsp;
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
all&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;
<a href=3D"http://192.168.2.120/24">192.168.2.120/24</a>&nbsp;&nbsp;&nbsp;&=
nbsp;&nbsp;&nbsp; md5<br>
<br>
# IPv4 local connections:<br>
host&nbsp;&nbsp;&nbsp;
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
<a href=3D"http://127.0.0.1/32">127.0.0.1/32</a>&nbsp;&nbsp;&nbsp;&nbsp;&nb=
sp;&nbsp;&nbsp;&nbsp;&nbsp; md5<br>
host&nbsp;&nbsp;&nbsp;
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
all&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
<a href=3D"http://192.168.2.120">192.168.2.120</a> <a href=3D"http://255.25=
5.255.255">255.255.255.255</a> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp; md5<br>
<br>
I have a Symantec personal firewall installed which I turned off during tes=
ting. <br>
<br>
The program runs fine on localhost.<br>
<br>
Am using the Npgsql .NET library.&nbsp; The Npgsql.Npgsql.Open() call
throws an exception, the error text of which is
&quot;System.Net.Sockets.SocketException: NO connection could be made
because the target machine actively refused it.&quot;<br>
<br>


------=_Part_862_25805662.1127892794651--

Report this message

#2: Re: Configure foreign host for PostgreSQL 8.0.3 on WindowsXP

Posted on 2005-09-28 10:14:11 by Magnus Hagander

> Installed PostgreSQL 8.0.3 on WindowsXP. Have not been able=20
> to configure so that a client program running on a different=20
> WindowsXP box can connect to the PostgreSQL database.=20
>=20
> As I understand the documentation, at least one of the=20
> following configurations should work, but none do. What have=20
> I done wrong and how can I configure so that a connection can=20
> be successfully made?
>=20
>=20
> 1) The postgresql.conf file has (with everything else being=20
> the installation default values):=20
>=20
> listen_addresses =3D '*'
>=20
> 2) None of the following configurations of the pg_hba.conf=20
> file worked (the program runs on 192.168.2.120):
>=20
> # IPv4 local connections:
> #host all all 127.0.0.1/32 md5
> host all all 192.168.2.120/24 md5
>=20
> # IPv4 local connections:
> #host all all 127.0.0.1/32 md5
> host all all 192.168.2.120=20
> 255.255.255.255 md5
>=20
> # IPv4 local connections:
> host all all 127.0.0.1/32 md5
> host all all 192.168.2.120/24 md5
>=20
> # IPv4 local connections:
> host all all 127.0.0.1/32 md5
> host all all 192.168.2.120=20
> 255.255.255.255 md5
>=20
> I have a Symantec personal firewall installed which I turned=20
> off during testing.=20
>=20
> The program runs fine on localhost.
>=20
> Am using the Npgsql .NET library. The Npgsql.Npgsql.Open()=20
> call throws an exception, the error text of which is=20
> "System.Net.Sockets.SocketException: NO connection could be=20
> made because the target machine actively refused it."

Check:
1) the listen_address=3D'*' didn't "take". Make sure you remembered to
remove the comment sign (yup, i've seen that mistake manu times). Also,
you need to restart the service after you've changed that, perhaps you
forgot it?
2) Is there any chance that the postmaster is running on a non-default
port? Or that the client is connecting on a non-standard port?
3) Verify that the IP Npgsql connects to is correct. If you're using a
DNS name, make sure it resolves right.

If all those look right, run a "netstat -na" on the commandline and see
if there is a listener to port 5432 and what IP that one is bound to.

//Magnus

---------------------------(end of broadcast)---------------------------
TIP 6: explain analyze is your friend

Report this message

#3: Re: Configure foreign host for PostgreSQL 8.0.3 on WindowsXP

Posted on 2005-09-28 14:57:27 by Dario

this line
host all all 192.168.2.120/24 md5
----------------

makes no sense to me, and probably neither to postgresql, it should be:
192.168.2.120/32 # if 192.168.2.120 is your client, this should be
enough
or
192.168.2.0/24 # if you wanted to allow all host in subnet to
validate thru md5, use this


long life, little spam and prosper.

-----Mensaje original-----
De: pgsql-admin-owner@postgresql.org
[mailto:pgsql-admin-owner@postgresql.org]En nombre de Magnus Hagander
Enviado el: miercoles, 28 de septiembre de 2005 5:14
Para: Todd Rockhold; pgsql-admin@postgresql.org
Asunto: Re: [ADMIN] Configure foreign host for PostgreSQL 8.0.3 on
WindowsXP


> Installed PostgreSQL 8.0.3 on WindowsXP. Have not been able
> to configure so that a client program running on a different
> WindowsXP box can connect to the PostgreSQL database.
>
> As I understand the documentation, at least one of the
> following configurations should work, but none do. What have
> I done wrong and how can I configure so that a connection can
> be successfully made?
>
>
> 1) The postgresql.conf file has (with everything else being
> the installation default values):
>
> listen_addresses = '*'
>
> 2) None of the following configurations of the pg_hba.conf
> file worked (the program runs on 192.168.2.120):
>
> # IPv4 local connections:
> #host all all 127.0.0.1/32 md5
> host all all 192.168.2.120/24 md5
>
> # IPv4 local connections:
> #host all all 127.0.0.1/32 md5
> host all all 192.168.2.120
> 255.255.255.255 md5
>
> # IPv4 local connections:
> host all all 127.0.0.1/32 md5
> host all all 192.168.2.120/24 md5
>
> # IPv4 local connections:
> host all all 127.0.0.1/32 md5
> host all all 192.168.2.120
> 255.255.255.255 md5
>
> I have a Symantec personal firewall installed which I turned
> off during testing.
>
> The program runs fine on localhost.
>
> Am using the Npgsql .NET library. The Npgsql.Npgsql.Open()
> call throws an exception, the error text of which is
> "System.Net.Sockets.SocketException: NO connection could be
> made because the target machine actively refused it."

Check:
1) the listen_address='*' didn't "take". Make sure you remembered to
remove the comment sign (yup, i've seen that mistake manu times). Also,
you need to restart the service after you've changed that, perhaps you
forgot it?
2) Is there any chance that the postmaster is running on a non-default
port? Or that the client is connecting on a non-standard port?
3) Verify that the IP Npgsql connects to is correct. If you're using a
DNS name, make sure it resolves right.

If all those look right, run a "netstat -na" on the commandline and see
if there is a listener to port 5432 and what IP that one is bound to.

//Magnus

---------------------------(end of broadcast)---------------------------
TIP 6: explain analyze is your friend


---------------------------(end of broadcast)---------------------------
TIP 9: In versions below 8.0, the planner will ignore your desire to
choose an index scan if your joining column's datatypes do not
match

Report this message

#4: Re: Configure foreign host for PostgreSQL 8.0.3 on WindowsXP

Posted on 2005-09-29 06:46:52 by Manikandan C

This is a multi-part message in MIME format.

------_=_NextPart_001_01C5C4B0.BE8ADBC5
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

Try disabling firewall. Because it may prevent any connections to your =
machine.
=20
Regards,
Mani

-----Original Message-----
From: pgsql-admin-owner@postgresql.org =
[mailto:pgsql-admin-owner@postgresql.org]On Behalf Of Todd Rockhold
Sent: Wednesday, September 28, 2005 1:03 PM
To: pgsql-admin@postgresql.org
Subject: [ADMIN] Configure foreign host for PostgreSQL 8.0.3 on =
WindowsXP


Installed PostgreSQL 8.0.3 on WindowsXP. Have not been able to =
configure so that a client program running on a different WindowsXP box =
can connect to the PostgreSQL database.=20

As I understand the documentation, at least one of the following =
configurations should work, but none do. What have I done wrong and how =
can I configure so that a connection can be successfully made?


1) The postgresql.conf file has (with everything else being the =
installation default values):=20

listen_addresses =3D '*'

2) None of the following configurations of the pg_hba.conf file worked =
(the program runs on 192.168.2.120):

# IPv4 local connections:
#host all all 127.0.0.1/32 md5
host all all 192.168.2.120/24 md5

# IPv4 local connections:
#host all all 127.0.0.1/32 md5
host all all 192.168.2.120 255.255.255.255 =
md5

# IPv4 local connections:
host all all 127.0.0.1/32 md5
host all all 192.168.2.120/24 md5

# IPv4 local connections:
host all all 127.0.0.1/32 md5
host all all 192.168.2.120 255.255.255.255 =
md5

I have a Symantec personal firewall installed which I turned off during =
testing.=20

The program runs fine on localhost.

Am using the Npgsql .NET library. The Npgsql.Npgsql.Open() call throws =
an exception, the error text of which is =
"System.Net.Sockets.SocketException: NO connection could be made because =
the target machine actively refused it."




------_=_NextPart_001_01C5C4B0.BE8ADBC5
Content-Type: text/html;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META HTTP-EQUIV=3D"Content-Type" CONTENT=3D"text/html; =
charset=3Diso-8859-1">


<META content=3D"MSHTML 6.00.2800.1515" name=3DGENERATOR></HEAD>
<BODY>
<DIV><FONT face=3DArial color=3D#0000ff size=3D2><SPAN =
class=3D652314504-29092005>Try=20
disabling firewall. Because it may prevent any connections to your=20
machine.</SPAN></FONT></DIV>
<DIV><FONT face=3DArial color=3D#0000ff size=3D2><SPAN=20
class=3D652314504-29092005></SPAN></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial color=3D#0000ff size=3D2><SPAN=20
class=3D652314504-29092005>Regards,</SPAN></FONT></DIV>
<DIV><FONT face=3DArial color=3D#0000ff size=3D2><SPAN=20
class=3D652314504-29092005>Mani</SPAN></FONT></DIV>
<BLOCKQUOTE>
<DIV class=3DOutlookMessageHeader dir=3Dltr align=3Dleft><FONT =
face=3DTahoma=20
size=3D2>-----Original Message-----<BR><B>From:</B>=20
pgsql-admin-owner@postgresql.org=20
[mailto:pgsql-admin-owner@postgresql.org]<B>On Behalf Of </B>Todd=20
Rockhold<BR><B>Sent:</B> Wednesday, September 28, 2005 1:03 =
PM<BR><B>To:</B>=20
pgsql-admin@postgresql.org<BR><B>Subject:</B> [ADMIN] Configure =
foreign host=20
for PostgreSQL 8.0.3 on WindowsXP<BR><BR></FONT></DIV>Installed =
PostgreSQL=20
8.0.3 on WindowsXP.&nbsp; Have not been able to configure so that a =
client=20
program running on a different WindowsXP box can connect to the =
PostgreSQL=20
database. <BR><BR>As I understand the documentation, at least one of =
the=20
following configurations should work, but none do.&nbsp; What have I =
done=20
wrong and how can I configure so that a connection can be successfully =

made?<BR><BR><BR>1) The postgresql.conf file has (with everything else =
being=20
the installation default values): <BR><BR>listen_addresses =3D =
'*'<BR><BR>2)=20
None of the following configurations of the pg_hba.conf file worked =
(the=20
program runs on <A =
href=3D"http://192.168.2.120">192.168.2.120</A>):<BR><BR>#=20
IPv4 local connections:<BR>#host&nbsp;&nbsp;&nbsp;=20
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;=20
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; <A=20
=
href=3D"http://127.0.0.1/32">127.0.0.1/32</A>&nbsp;&nbsp;&nbsp;&nbsp;&nbs=
p;&nbsp;&nbsp;&nbsp;&nbsp;=20
md5<BR>host&nbsp;&nbsp;&nbsp;=20
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
all&nbsp;&nbsp;&nbsp;=20
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; <A=20
=
href=3D"http://192.168.2.120/24">192.168.2.120/24</A>&nbsp;&nbsp;&nbsp;&n=
bsp;&nbsp;&nbsp;=20
md5<BR><BR># IPv4 local connections:<BR>#host&nbsp;&nbsp;&nbsp;=20
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;=20
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; <A=20
=
href=3D"http://127.0.0.1/32">127.0.0.1/32</A>&nbsp;&nbsp;&nbsp;&nbsp;&nbs=
p;&nbsp;&nbsp;&nbsp;&nbsp;=20
md5<BR>host&nbsp;&nbsp;&nbsp;=20
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
all&nbsp;&nbsp;&nbsp;=20
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; <A=20
href=3D"http://192.168.2.120">192.168.2.120</A> <A=20
href=3D"http://255.255.255.255">255.255.255.255</A>=20
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; md5<BR><BR># IPv4 local=20
connections:<BR>host&nbsp;&nbsp;&nbsp;=20
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;=20
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; <A=20
=
href=3D"http://127.0.0.1/32">127.0.0.1/32</A>&nbsp;&nbsp;&nbsp;&nbsp;&nbs=
p;&nbsp;&nbsp;&nbsp;&nbsp;=20
md5<BR>host&nbsp;&nbsp;&nbsp;=20
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
all&nbsp;&nbsp;&nbsp;=20
&nbsp;&nbsp;&nbsp;&nbsp; <A=20
=
href=3D"http://192.168.2.120/24">192.168.2.120/24</A>&nbsp;&nbsp;&nbsp;&n=
bsp;&nbsp;&nbsp;=20
md5<BR><BR># IPv4 local connections:<BR>host&nbsp;&nbsp;&nbsp;=20
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;=20
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; <A=20
=
href=3D"http://127.0.0.1/32">127.0.0.1/32</A>&nbsp;&nbsp;&nbsp;&nbsp;&nbs=
p;&nbsp;&nbsp;&nbsp;&nbsp;=20
md5<BR>host&nbsp;&nbsp;&nbsp;=20
all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
all&nbsp;&nbsp;&nbsp;=20
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; <A=20
href=3D"http://192.168.2.120">192.168.2.120</A> <A=20
href=3D"http://255.255.255.255">255.255.255.255</A>=20
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; md5<BR><BR>I have a Symantec personal =
firewall=20
installed which I turned off during testing. <BR><BR>The program runs =
fine on=20
localhost.<BR><BR>Am using the Npgsql .NET library.&nbsp; The=20
Npgsql.Npgsql.Open() call throws an exception, the error text of which =
is=20
"System.Net.Sockets.SocketException: NO connection could be made =
because the=20
target machine actively refused =
it."<BR><BR></BLOCKQUOTE></BODY></HTML>

------_=_NextPart_001_01C5C4B0.BE8ADBC5--

Report this message

#5: Re: Configure foreign host for PostgreSQL 8.0.3 on WindowsXP

Posted on 2005-09-30 05:27:31 by Todd Rockhold

------=_Part_594_24894728.1128050851417
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Thanks to all who responded. I'm a bit strapped for time now so I won't
publish a detailed analysis of what was wrong. Several of the suggestions
provided were helpful and more than one thing was wrong with my setup. The
program is working now on the client machine.

Thanks again for the help.

------=_Part_594_24894728.1128050851417
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

<br>Thanks to all who responded.&nbsp; I'm a bit strapped for time now
so I won't publish a detailed analysis of what was wrong.&nbsp; Several
of the suggestions provided were helpful and more than one thing was
wrong with my setup.&nbsp; The program is working now on the client
machine.<br>
<br>
Thanks again for the help.<br>
<br>
<br>

------=_Part_594_24894728.1128050851417--

Report this message