Bookmarks

Yahoo Gmail Google Facebook Delicious Twitter Reddit Stumpleupon Myspace Digg

Search queries

sqldatasource dal, wwwxxxenden, convert raid5 to raid 10 mdadm, apache force chunked, nrao wwwxxx, xxxxxdup, procmail change subject header, wwwXxx not20, Wwwxxx.doks sas, linux raid resync after reboot

Links

XODOX
Impressum

#1: redirect to https

Posted on 2006-10-31 15:38:40 by Roel Bindels

Hello Listers,

I'm having the following problem. I want to redirect a adress to
internal server. If I use this same config for a non ssl site, there is
no problem, but when I use it like the config below I get an

Bad Request
Your browser sent a request that this server could not understand.

This is my config...

<VirtualHost *>
ServerAdmin Roel.Bindels@xxxxxxxxx.xx
ServerName vmware.xxxxxxxxx.xx

ProxyPass / https://10.0.0.108:8333/
ProxyPassReverse / https://10.0.0.108:8333/

</VirtualHost>


Can somebody tell what I am doing wrong??

greetings
Roel

Report this message

#2: Re: redirect to https

Posted on 2006-11-01 10:21:31 by James Blond

Hello!
Did you load mod_proxy_connect for SSL connection?


> Bad Request
> Your browser sent a request that this server could not understand.

> ProxyPass / https://10.0.0.108:8333/
> ProxyPassReverse / https://10.0.0.108:8333/


greets
Mario

Report this message

#3: Re: redirect to https

Posted on 2006-11-01 13:22:23 by Roel Bindels

James Blond wrote:
> Hello!
> Did you load mod_proxy_connect for SSL connection?
>

No I did not had this module loaded. But after loading this the result
still is Bad Request.

More Ideas????

greetings
Roel

>
>> Bad Request
>> Your browser sent a request that this server could not understand.
>
>> ProxyPass / https://10.0.0.108:8333/
>> ProxyPassReverse / https://10.0.0.108:8333/
>
>
> greets
> Mario
>

Report this message

#4: Re: redirect to https

Posted on 2006-11-01 14:06:25 by James Blond

A full working solution which also rewrite the links (need mod_ptoxy_html)

LoadModule rewrite_module modules/mod_rewrite.so
LoadModule headers_module modules/mod_headers.so

LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_ajp_module modules/mod_proxy_ajp.so
LoadModule proxy_balancer_module modules/mod_proxy_balancer.so
LoadModule proxy_connect_module modules/mod_proxy_connect.so
LoadModule proxy_http_module modules/mod_proxy_http.so
LoadModule proxy_ftp_module modules/mod_proxy_ftp.so

LoadModule proxy_html_module modules/mod_proxy_html.so
LoadFile /server2/apache/bin/libxml2.so

ProxyRequests Off
<Proxy *>

Order deny,allow
Allow from all

</Proxy>


ProxyPass /bigwig http://192.168.0.8/bigwig/
ProxyPassReverse /bigwig http://192.168.0.8/bigwig/
ProxyHTMLURLMap http://192.168.0.8/bigwig/ /bigwig

<Location /bigwig>
ProxyPassReverse /
SetOutputFilter proxy-html
ProxyHTMLURLMap / /bigwig/
ProxyHTMLURLMap /bigwig /bigwig
RequestHeader unset Accept-Encoding
</Location>

greets
Mario

On 11/1/06, Roel Bindels <rbindels@gmail.com> wrote:
> James Blond wrote:
> > Hello!
> > Did you load mod_proxy_connect for SSL connection?
> >
>
> No I did not had this module loaded. But after loading this the result
> still is Bad Request.
>
> More Ideas????
>
> greetings
> Roel
>
> >
> >> Bad Request
> >> Your browser sent a request that this server could not understand.
> >
> >> ProxyPass / https://10.0.0.108:8333/
> >> ProxyPassReverse / https://10.0.0.108:8333/
> >
> >
> > greets
> > Mario
> >
>
>

Report this message