Bookmarks

Yahoo Gmail Google Facebook Delicious Twitter Reddit Stumpleupon Myspace Digg

Search queries



Links

Issociate
Impressum

#1: Reverse Proxy Timeout (http/https)

Posted on 2007-03-21 09:56:11 by Sim

Hi! I have configurated Apache in Reverse Proxy, for one "Apche
front-end" of "MS Exchange 2003"

This work very well, but some times I receved timeout errors from Exchange.=
[

The average of the most recent [200] heartbeat intervals used by
clients is less than or equal to [9]. Make sure that your firewall
configuration is set to work correctly with Exchange ActiveSync and
direct push technology. Specifically, make sure that your firewall is
configured so that requests to Exchange ActiveSync do not expire
before they have the opportunity to be processed.
http://www.eventid.net/display.asp?eventid=3D3033&eventno=3D 7241&source=3D=
Server%20ActiveSync&phase=3D1
]

Is there a solution to increase http/https TimeOut session for reverse
proxy, or another solutions? For example KeepAlive?

Excuse me but I'm not expert in this Reverse Proxy method.

My config: ROUTER<--------ETH0->Apache Reverse
Proxy<-ETH1-------EXCHANGE (192.168.0.2)

-----------------------------------------------------
ProxyRequests Off
ProxyPreserveHost On
SSLProxyEngine On

#OWA % character in email subject fix
RewriteEngine On
RewriteMap percentsubject int:escape
RewriteCond $1 ^/exchange/.*\%.*$
RewriteRule (/exchange/.*) ${percentsubject:$1} [P]

# =E0 =E8 ...
AddDefaultCharset utf-8

# OWA

ProxyPass https://192.168.0.2/exchange
ProxyPassReverse https://192.168.0.2/exchange
SSLRequireSSL


ProxyPass https://192.168.0.2/exchweb
ProxyPassReverse https://192.168.0.2/exchweb
SSLRequireSSL


ProxyPass https://192.168.0.2/public
ProxyPassReverse https://192.168.0.2/public
SSLRequireSSL


# OMA

ProxyPass https://192.168.0.2/oma
ProxyPassReverse https://192.168.0.2/oma
SSLRequireSSL


# ActiveSync (for WM5+ devices)

ProxyPass http://192.168.0.2/Microsoft-Server-ActiveSync
ProxyPassReverse http://192.168.0.2/Microsoft-Server-Active=
Sync
# SSLRequireSSL

-----------------------------------------------------

Thanks!

Sim

------------------------------------------------------------ ---------
The official User-To-User support forum of the Apache HTTP Server Project.
See for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
" from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

Report this message

Mr Ad

Google

#2: RE: Reverse Proxy Timeout (http/https)

Posted on 2007-03-21 17:09:28 by steve.foster

Hi there,

i have implemented the following on my apache server for the =
proxytimeout

ProxyTimeout 120

And also set the following to catch the 502 error that mod_proxy gives =
when it times out to the server being proxied to. This allows you to =
produce a branded page to give to the client rather than the standard =
"Bad Gateway" error that is produced.

e.g:

# =
==================== =====3D=
==================== ===3D
# Error Handling
# =
==================== =====3D=
==================== ==
ErrorDocument 502 /error/proxytimedout.htm

HTH

Steve

-----Original Message-----
From: Sim [mailto:simvirus@gmail.com]
Sent: 21 March 2007 08:56
To: users@httpd.apache.org
Subject: [users@httpd] Reverse Proxy Timeout (http/https)


Hi! I have configurated Apache in Reverse Proxy, for one "Apche
front-end" of "MS Exchange 2003"

This work very well, but some times I receved timeout errors from =
Exchange. [

The average of the most recent [200] heartbeat intervals used by
clients is less than or equal to [9]. Make sure that your firewall
configuration is set to work correctly with Exchange ActiveSync and
direct push technology. Specifically, make sure that your firewall is
configured so that requests to Exchange ActiveSync do not expire
before they have the opportunity to be processed.
=
http://www.eventid.net/display.asp?eventid=3D3033&eventno=3D 7241&source=3D=
Server%20ActiveSync&phase=3D1
]

Is there a solution to increase http/https TimeOut session for reverse
proxy, or another solutions? For example KeepAlive?

Excuse me but I'm not expert in this Reverse Proxy method.

My config: ROUTER<--------ETH0->Apache Reverse
Proxy<-ETH1-------EXCHANGE (192.168.0.2)

-----------------------------------------------------
ProxyRequests Off
ProxyPreserveHost On
SSLProxyEngine On

#OWA % character in email subject fix
RewriteEngine On
RewriteMap percentsubject int:escape
RewriteCond $1 ^/exchange/.*\%.*$
RewriteRule (/exchange/.*) ${percentsubject:$1} [P]

# =E0 =E8 ...
AddDefaultCharset utf-8

# OWA

ProxyPass https://192.168.0.2/exchange
ProxyPassReverse https://192.168.0.2/exchange
SSLRequireSSL


ProxyPass https://192.168.0.2/exchweb
ProxyPassReverse https://192.168.0.2/exchweb
SSLRequireSSL


ProxyPass https://192.168.0.2/public
ProxyPassReverse https://192.168.0.2/public
SSLRequireSSL


# OMA

ProxyPass https://192.168.0.2/oma
ProxyPassReverse https://192.168.0.2/oma
SSLRequireSSL


# ActiveSync (for WM5+ devices)

ProxyPass http://192.168.0.2/Microsoft-Server-ActiveSync
ProxyPassReverse =
http://192.168.0.2/Microsoft-Server-ActiveSync
# SSLRequireSSL

-----------------------------------------------------

Thanks!

Sim

------------------------------------------------------------ ---------
The official User-To-User support forum of the Apache HTTP Server =
Project.
See for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
" from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


------------------------------------------------------------ ---------
The official User-To-User support forum of the Apache HTTP Server Project.
See for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
" from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

Report this message

#3: Re: Reverse Proxy Timeout (http/https)

Posted on 2007-03-22 08:59:57 by Sim

> i have implemented the following on my apache server for the proxytimeout
>
> ProxyTimeout 120
>
> And also set the following to catch the 502 error that mod_proxy gives when it times out to the server being proxied to. This allows you to produce a branded page to give to the client rather than the standard "Bad Gateway" error that is produced.
>

Hello! Thanks for reply.

I have set ProxyTimeout to 900 but actually this is my log.

[22/Mar/2007:07:36:23 +0100] "POST
/Microsoft-Server-ActiveSync?User=sim&DeviceId=5EBC5C9BD6A1D B7747591DD1C331C418&DeviceType=PocketPC&Cmd=Sync
HTTP/1.1" 200 290 "-" "MSFT-PPC/5.1.3200"
[22/Mar/2007:07:36:36 +0100] "POST
/Microsoft-Server-ActiveSync?User=sim&DeviceId=5EBC5C9BD6A1D B7747591DD1C331C418&DeviceType=PocketPC&Cmd=Sync
HTTP/1.1" 200 815 "-" "MSFT-PPC/5.1.3200"
[22/Mar/2007:07:36:41 +0100] "POST
/Microsoft-Server-ActiveSync?User=sim&DeviceId=5EBC5C9BD6A1D B7747591DD1C331C418&DeviceType=PocketPC&Cmd=Sync
HTTP/1.1" 200 259 "-" "MSFT-PPC/5.1.3200"
[22/Mar/2007:07:36:44 +0100] "POST
/Microsoft-Server-ActiveSync?User=sim&DeviceId=5EBC5C9BD6A1D B7747591DD1C331C418&DeviceType=PocketPC&Cmd=Ping
HTTP/1.1" 502 668 "-" "MSFT-PPC/5.1.3200"
[22/Mar/2007:07:41:51 +0100] "POST
/Microsoft-Server-ActiveSync?User=sim&DeviceId=5EBC5C9BD6A1D B7747591DD1C331C418&DeviceType=PocketPC&Cmd=GetItemEstimate
HTTP/1.1" 200 334 "-" "MSFT-PPC/5.1.3200"
[22/Mar/2007:07:44:46 +0100] "POST
/Microsoft-Server-ActiveSync?User=sim&DeviceId=5EBC5C9BD6A1D B7747591DD1C331C418&DeviceType=PocketPC&Cmd=Ping
HTTP/1.1" 502 668 "-" "MSFT-PPC/5.1.3200"


Are important for this problem: KeepAliveTimeout , KeepAlive On
and ProxyPass timeout/ttl ?

Very thanks.

Sim

------------------------------------------------------------ ---------
The official User-To-User support forum of the Apache HTTP Server Project.
See for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
" from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

Report this message

#4: RE: Reverse Proxy Timeout (http/https)

Posted on 2007-03-22 22:55:35 by Steve Gums

I have a problem related to this, maybe I could get some help with. My
configuration is a follows

ServerAdmin me@domain.com
ServerName go.domain.com
ProxyPass / http://go.domain.com/
ProxyPassReverse / httpd://go.domain.com/
Options all +includes


This setup works about 70% of the time. I am trying to proxy to an IIS
server, I receive the 502 Error immediately when it occurs so I do not
believe the timeout is the issue. When I access the server internally the
response is good.

"The Proxy Server could not handle the request GET/default.aspx"
Would be the exact error I am getting.

Can someone please tell me what I did wrong I need this thing to work
reliably. At least as reliable as windows IIS gets. I pretty sure it's
better then 70% on good days.

Steve

-----Original Message-----
From: Sim [mailto:simvirus@gmail.com]
Sent: Thursday, March 22, 2007 2:00 AM
To: users@httpd.apache.org
Subject: Re: [users@httpd] Reverse Proxy Timeout (http/https)

> i have implemented the following on my apache server for the proxytimeout
>
> ProxyTimeout 120
>
> And also set the following to catch the 502 error that mod_proxy gives
when it times out to the server being proxied to. This allows you to produce
a branded page to give to the client rather than the standard "Bad Gateway"
error that is produced.
>

Hello! Thanks for reply.

I have set ProxyTimeout to 900 but actually this is my log.

[22/Mar/2007:07:36:23 +0100] "POST
/Microsoft-Server-ActiveSync?User=sim&DeviceId=5EBC5C9BD6A1D B7747591DD1C331C
418&DeviceType=PocketPC&Cmd=Sync
HTTP/1.1" 200 290 "-" "MSFT-PPC/5.1.3200"
[22/Mar/2007:07:36:36 +0100] "POST
/Microsoft-Server-ActiveSync?User=sim&DeviceId=5EBC5C9BD6A1D B7747591DD1C331C
418&DeviceType=PocketPC&Cmd=Sync
HTTP/1.1" 200 815 "-" "MSFT-PPC/5.1.3200"
[22/Mar/2007:07:36:41 +0100] "POST
/Microsoft-Server-ActiveSync?User=sim&DeviceId=5EBC5C9BD6A1D B7747591DD1C331C
418&DeviceType=PocketPC&Cmd=Sync
HTTP/1.1" 200 259 "-" "MSFT-PPC/5.1.3200"
[22/Mar/2007:07:36:44 +0100] "POST
/Microsoft-Server-ActiveSync?User=sim&DeviceId=5EBC5C9BD6A1D B7747591DD1C331C
418&DeviceType=PocketPC&Cmd=Ping
HTTP/1.1" 502 668 "-" "MSFT-PPC/5.1.3200"
[22/Mar/2007:07:41:51 +0100] "POST
/Microsoft-Server-ActiveSync?User=sim&DeviceId=5EBC5C9BD6A1D B7747591DD1C331C
418&DeviceType=PocketPC&Cmd=GetItemEstimate
HTTP/1.1" 200 334 "-" "MSFT-PPC/5.1.3200"
[22/Mar/2007:07:44:46 +0100] "POST
/Microsoft-Server-ActiveSync?User=sim&DeviceId=5EBC5C9BD6A1D B7747591DD1C331C
418&DeviceType=PocketPC&Cmd=Ping
HTTP/1.1" 502 668 "-" "MSFT-PPC/5.1.3200"


Are important for this problem: KeepAliveTimeout , KeepAlive On
and ProxyPass timeout/ttl ?

Very thanks.

Sim

------------------------------------------------------------ ---------
The official User-To-User support forum of the Apache HTTP Server Project.
See for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
" from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org



------------------------------------------------------------ ---------
The official User-To-User support forum of the Apache HTTP Server Project.
See for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
" from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

Report this message