Bookmarks

Yahoo Gmail Google Facebook Delicious Twitter Reddit Stumpleupon Myspace Digg

Search queries

Use of assignment to $[ is deprecated at /usr/local/sbin/apxs line 86. , wwwxxx vim, mysql closing table and opening table, 800c5000, setgid operation not permitted, pciehp: acpi_pciehprm on IBM, WWWXXX.DBF, 078274121, info0a ip, should prodicers of software_based services be held liable or not liable for economic injuries

Links

XODOX
Impressum

#1: Re: question for DBD-Oracle driver

Posted on 2008-04-08 18:35:24 by pgodfrin

On Mar 28, 2:05 pm, Fred.Vac...@CIGNA.COM (Frederick P A5IT Vachon)
wrote:
> Hi - I have an issue related to this. I have DBI and DBD::Oracle
> installed on a Solaris 10 machine. When I run either of the 2 commands
> that were posted I error out with the messages listed below.
>
> perl -e 'use DBD::Oracle 42'
> perl -MDBD::Oracle -le 'print $DBD::Oracle::VERSION;'
>
> I'm thinking it might be an issue with PATH or LD_LIBRARY_PATH but I
> haven't been able to find it. I've tried using the sparcv9 libraries
> thinking it might be a 32 vs 64 bit issue but nothing works. Does
> anyone have any suggestions? Thanks for any help.
>
> perl -MDBD::Oracle -le 'print $DBD::Oracle::VERSION;'
> Can't load
> '/usr/perl5/site_perl/5.8.4/sun4-solaris-64int/auto/DBD/Orac le/Oracle.so
> ' for module DBD::Oracle: ld.so.1: perl: fatal: .
> at -e line 0
> Compilation failed in require.
> BEGIN failed--compilation aborted.
>
> perl -e 'use DBD::Oracle 42'
> Can't load
> '/usr/perl5/site_perl/5.8.4/sun4-solaris-64int/auto/DBD/Orac le/Oracle.so
> ' for module DBD::Oracle: ld.so.1: perl: fatal: .
> at -e line 1
> Compilation failed in require at -e line 1.
> BEGIN failed--compilation aborted at -e line 1.
>
> i...@wt.net wrote:
>
> -> Dear sir/madam,
>
>
>
> > How can we tell that we have already install DBD-Oracle drive for
> > DBI ?
>
> perl -MDBD::Oracle -le 'print $DBD::Oracle::VERSION;'
>
> which will error with "Can't locate DBD::Oracle"... if you haven't got
> it.
>
> > If we have already install DBD-Oracle, how can we check what version
> > it is ?
>
> perl -MDBD::Oracle -le 'print $DBD::Oracle::VERSION;'
>
> will show DBD::Oracle version.
>
> -----Original Message-----
> From: Ian Harisay [mailto:imhar...@nuskin.com]
> Sent: Friday, March 28, 2008 12:36 PM
> To: dbi-us...@perl.org
> Subject: RE: question for DBD-Oracle driver
>
> perl -e 'use DBD::Oracle 42'
>
> This will tell you what version is currently installed. Generally, I
> always refer to the man page first. But, I didn't see versioning info
> available in the DBD::Oracle man page. Probably an oversite on my part.
>
> ------------------------------------------------------------ ------------------
> CONFIDENTIALITY NOTICE: If you have received this email in error, please immediately notify the sender by e-mail at the address shown. This email transmission may contain confidential information. This information is intended only for the use of the individual(s) or entity to whom it is intended even if addressed incorrectly. Please delete it from your files if you are not the intended recipient. Thank you for your compliance. Copyright 2008 CIGNA
> ============================================================ ==================

what about perl -MDBI -e 'DBI->installed_versions' ?

phil

Report this message