Bookmarks

Yahoo Gmail Google Facebook Delicious Twitter Reddit Stumpleupon Myspace Digg

Search queries

w2ksp4.exe, WwwxxXdbf, procmail "FROM_MAILER" patch, Use of assignment to $[ is deprecated at /usr/local/sbin/apxs line 86. , wwwxxx vim, mysql closing table and opening table, 800c5000, setgid operation not permitted, pciehp: acpi_pciehprm on IBM, WWWXXX.DBF

Links

XODOX
Impressum

#1: Metabase.XML: AspMaxRequestEntityAllowed

Posted on 2008-04-16 21:19:33 by Nook

Windows Server 2003 SP2
IIS 6.0
C:\WINDOWS\system32\inetsrv\MetaBase.xml

Default Setting in MetaBase.xml:
AspMaxRequestEntityAllowed="204800"
Results in this error for one of our development web pages:

a.. Error Type:
Request object, ASP 0104 (0x80004005)
Operation not Allowed
/dev/ritu/vbrc_trunk/vbrc/exportSequenceAsFastA.asp, line 59
a.. Browser Type:
Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET
CLR 2.0.50727; InfoPath.2; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648)
a.. Page:
POST 347806 bytes to /dev/ritu/vbrc_trunk/vbrc/exportSequenceAsFastA.asp
a.. POST Data:

Attempting to change the value to 1GB
AspMaxRequestEntityAllowed="1073741824"
while IIS is shut down (and then starting IIS) sometimes results in us
getting past the error. Other times, not.

Also, the value somehow automatically resets to
AspMaxRequestEntityAllowed="204800"
every time. It might happen with in one minute of our modification, or it
might be several minutes later.

It is difficult to tell what exactly is happening here. Any insights would
be deeply appreciated. :)

Jim

Report this message

#2: Re: Metabase.XML: AspMaxRequestEntityAllowed

Posted on 2008-04-17 03:42:29 by David Wang

On Apr 16, 12:19=A0pm, "Jim" <nore...@noreply.com> wrote:
> Windows Server 2003 SP2
> IIS 6.0
> C:\WINDOWS\system32\inetsrv\MetaBase.xml
>
> Default Setting in MetaBase.xml:
> AspMaxRequestEntityAllowed=3D"204800"
> Results in this error for one of our development web pages:
>
> a.. Error Type:
> Request object, ASP 0104 (0x80004005)
> Operation not Allowed
> /dev/ritu/vbrc_trunk/vbrc/exportSequenceAsFastA.asp, line 59
> a.. Browser Type:
> Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET=

> CLR 2.0.50727; InfoPath.2; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648)
> a.. Page:
> POST 347806 bytes to /dev/ritu/vbrc_trunk/vbrc/exportSequenceAsFastA.asp
> a.. POST Data:
>
> Attempting to change the value to 1GB
> AspMaxRequestEntityAllowed=3D"1073741824"
> while IIS is shut down (and then starting IIS) sometimes results in us
> getting past the error. =A0Other times, not.
>
> Also, the value somehow automatically resets to
> AspMaxRequestEntityAllowed=3D"204800"
> every time. =A0It might happen with in one minute of our modification, or =
it
> might be several minutes later.
>
> It is difficult to tell what exactly is happening here. =A0Any insights wo=
uld
> be deeply appreciated. =A0:)
>
> Jim


If the value resets back to 204800 and you saw no events about IIS
Admin restarting, then you have something else (like Group Policy)
which is stamping the 204800 value and causing your issues. IIS cannot
change its configuration and has no feature to stamp configuration
values, so "resetting values" are always issues in the user's
environment.

AspMaxRequestEntityAllowed is about the REQUEST entity body. It does
not affect limits on the RESPONSE entity body, such as buffering.

It is difficult for me to tell what exactly is going on in your
environment. IIS behaviors are very simple and straightforward. If you
find otherwise, the problem is usually in your environment.


//David
http://w3-4u.blogspot.com
http://blogs.msdn.com/David.Wang
//

Report this message

#3: Re: Metabase.XML: AspMaxRequestEntityAllowed

Posted on 2008-04-17 20:46:22 by Nook

"David Wang" <w3.4you@gmail.com> wrote in message
news:a156a890-144f-4181-94b7-d246d1ecb650@8g2000hsu.googlegr oups.com...
On Apr 16, 12:19 pm, "Jim" <nore...@noreply.com> wrote:
> Windows Server 2003 SP2
> IIS 6.0
> C:\WINDOWS\system32\inetsrv\MetaBase.xml
>
> Default Setting in MetaBase.xml:
> AspMaxRequestEntityAllowed="204800"
> Results in this error for one of our development web pages:
>
> a.. Error Type:
> Request object, ASP 0104 (0x80004005)
> Operation not Allowed
> /dev/ritu/vbrc_trunk/vbrc/exportSequenceAsFastA.asp, line 59
> a.. Browser Type:
> Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET
> CLR 2.0.50727; InfoPath.2; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648)
> a.. Page:
> POST 347806 bytes to /dev/ritu/vbrc_trunk/vbrc/exportSequenceAsFastA.asp
> a.. POST Data:
>
> Attempting to change the value to 1GB
> AspMaxRequestEntityAllowed="1073741824"
> while IIS is shut down (and then starting IIS) sometimes results in us
> getting past the error. Other times, not.
>
> Also, the value somehow automatically resets to
> AspMaxRequestEntityAllowed="204800"
> every time. It might happen with in one minute of our modification, or it
> might be several minutes later.
>
> It is difficult to tell what exactly is happening here. Any insights would
> be deeply appreciated. :)
>
> Jim


If the value resets back to 204800 and you saw no events about IIS
Admin restarting, then you have something else (like Group Policy)
which is stamping the 204800 value and causing your issues. IIS cannot
change its configuration and has no feature to stamp configuration
values, so "resetting values" are always issues in the user's
environment.

AspMaxRequestEntityAllowed is about the REQUEST entity body. It does
not affect limits on the RESPONSE entity body, such as buffering.

It is difficult for me to tell what exactly is going on in your
environment. IIS behaviors are very simple and straightforward. If you
find otherwise, the problem is usually in your environment.


//David
http://w3-4u.blogspot.com
http://blogs.msdn.com/David.Wang
//


David,

Thank you for the valuable feedback. I am looking in Group Policy and see
Computer Configuration-->Administrative Templates-->Windows
Components-->Internet Information Services
Under IIS, there is only one item: "Prevent IIS installation".

I know of no one, on this server, setting anything such as
"AspMaxRequestEntityAllowed" to any value, by any means. Do you any ideas
where else or how else something like "AspMaxRequestEntityAllowed" might be
getting reset?

Jim

Report this message

#4: Re: Metabase.XML: AspMaxRequestEntityAllowed

Posted on 2008-04-18 00:16:28 by David Wang

On Apr 17, 11:46=A0am, "Jim" <nore...@noreply.com> wrote:
> "David Wang" <w3.4...@gmail.com> wrote in message
>
> news:a156a890-144f-4181-94b7-d246d1ecb650@8g2000hsu.googlegr oups.com...
> On Apr 16, 12:19 pm, "Jim" <nore...@noreply.com> wrote:
>
>
>
>
>
> > Windows Server 2003 SP2
> > IIS 6.0
> > C:\WINDOWS\system32\inetsrv\MetaBase.xml
>
> > Default Setting in MetaBase.xml:
> > AspMaxRequestEntityAllowed=3D"204800"
> > Results in this error for one of our development web pages:
>
> > a.. Error Type:
> > Request object, ASP 0104 (0x80004005)
> > Operation not Allowed
> > /dev/ritu/vbrc_trunk/vbrc/exportSequenceAsFastA.asp, line 59
> > a.. Browser Type:
> > Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .N=
ET
> > CLR 2.0.50727; InfoPath.2; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648=
)
> > a.. Page:
> > POST 347806 bytes to /dev/ritu/vbrc_trunk/vbrc/exportSequenceAsFastA.asp=

> > a.. POST Data:
>
> > Attempting to change the value to 1GB
> > AspMaxRequestEntityAllowed=3D"1073741824"
> > while IIS is shut down (and then starting IIS) sometimes results in us
> > getting past the error. Other times, not.
>
> > Also, the value somehow automatically resets to
> > AspMaxRequestEntityAllowed=3D"204800"
> > every time. It might happen with in one minute of our modification, or i=
t
> > might be several minutes later.
>
> > It is difficult to tell what exactly is happening here. Any insights wou=
ld
> > be deeply appreciated. :)
>
> > Jim
>
> If the value resets back to 204800 and you saw no events about IIS
> Admin restarting, then you have something else (like Group Policy)
> which is stamping the 204800 value and causing your issues. IIS cannot
> change its configuration and has no feature to stamp configuration
> values, so "resetting values" are always issues in the user's
> environment.
>
> AspMaxRequestEntityAllowed is about the REQUEST entity body. It does
> not affect limits on the RESPONSE entity body, such as buffering.
>
> It is difficult for me to tell what exactly is going on in your
> environment. IIS behaviors are very simple and straightforward. If you
> find otherwise, the problem is usually in your environment.
>
> //Davidhttp://w3-4u.blogspot.comhttp://blogs.msdn.com/David. Wang
> //
>
> David,
>
> Thank you for the valuable feedback. =A0I am looking in Group Policy and s=
ee
> Computer Configuration-->Administrative Templates-->Windows
> Components-->Internet Information Services
> Under IIS, there is only one item: =A0"Prevent IIS installation".
>
> I know of no one, on this server, setting anything such as
> "AspMaxRequestEntityAllowed" to any value, by any means. =A0Do you any ide=
as
> where else or how else something like "AspMaxRequestEntityAllowed" might b=
e
> getting reset?
>
> Jim- Hide quoted text -
>
> - Show quoted text -


You may have a rogue application, or Group Policy script, or some
other agent that is doing this change. You can turn on Metabase
Auditing in IIS6 to see what is changing that value. However, be aware
that in these cases, the user account audited is typically some
generic account used in automation and may not be specific enough for
you to figure our what is doing it. You will have have to be creative
in tracking down what is running in your environment.

Treat this like a necessary security exercise. You need to know and
control what is running on your server if you EVER hope to be able to
administer it correctly.


//David
http://w3-4u.blogspot.com
http://blogs.msdn.com/David.Wang
//

Report this message