Bookmarks

Yahoo Gmail Google Facebook Delicious Twitter Reddit Stumpleupon Myspace Digg

Search queries

w2ksp4.exe, WwwxxXdbf, procmail "FROM_MAILER" patch, Use of assignment to $[ is deprecated at /usr/local/sbin/apxs line 86. , wwwxxx vim, mysql closing table and opening table, 800c5000, setgid operation not permitted, pciehp: acpi_pciehprm on IBM, WWWXXX.DBF

Links

XODOX
Impressum

#1: Re: IIS gives 503 Service Unavailable

Posted on 2008-04-18 05:25:46 by Ken Schaefer

There is something wrong with your applicationHost.config file. This is the
central IIS configuration file.

If you don't have a working backup of this file, you could consider
uninstalling IIS. Then deleting the existing config files in
c:\windows\system32\inetsrv\config (you will need to use an elevated window
to do this), and then reinstalling IIS.

Also, install Vista SP1 (if you haven't already), as that has some fixes
(apparently) for some apphost.config corruption issues.

Cheers
Ken


"Fresno Bob" <nospam@nospam.com> wrote in message
news:EC919F0D-4145-48AF-95C9-8478E0407409@microsoft.com...
> Hi I ugraded to Ultimate from Business Premium and IIS doesn't work any
> more I get a 503 error - Service Unavailable. I create an application pool
> and then a web site that uses it. When I go to access the page via
> localhost I get the 503 error and the app pool stops
>
>
>
> This is an IIS issue as it affects html pages and not just aspx. When I
> look in the event log I see the following error -
>
>
>
> The worker process for application pool '*******' encountered an error
> 'Cannot read configuration file
>
> ' trying to read global module configuration data from file
> '\\?\C:\Windows\system32\inetsrv\config\applicationHost.conf ig', line
> number '0'. Worker process startup aborted.
>
>
> I have tried
>
> 1. Copying the applicationHost.config from an MS website in the config
> file was corrupted
>
> 2. Giving the Network Service read permissions to the
> C:\Windows\system32\inetsrv\config folder - however I was only successful
> with this once - I reinstalled IIS and now it won't let me add users to
> the folder.
>
>
>
> This is really frustrating - I paid a lot of money for this upgrade and a
> lot things, which I bought it for, don't work. Can anyone help regards,
> Chris.
>

Report this message

#2: Re: IIS gives 503 Service Unavailable

Posted on 2008-04-18 09:19:29 by Ken Schaefer

You can't do that, unfortunately. If you try to delete from within Explorer,
hopefully you'll be prompted and then you can delete.

If you are not prompted, and just get an Access Denied, then open Command
Prompt using "Run as Administrator" and delete the files that way.

Cheers
Ken

--
My IIS blog: http://adopenstatic.com/blog

"Fresno Bob" <nospam@nospam.com> wrote in message
news:2BBCD176-6D37-43D6-A202-B4694938082C@microsoft.com...
> Out of curiosity how do I do things like delete with an elevated
> privilage? Do you mean right click on e.g. Windows Explorer and run as
> Administrator.
>
>
> "Ken Schaefer" <kenREMOVE@THISadOpenStatic.com> wrote in message
> news:OV7snPQoIHA.3428@TK2MSFTNGP02.phx.gbl...
>> There is something wrong with your applicationHost.config file. This is
>> the central IIS configuration file.
>>
>> If you don't have a working backup of this file, you could consider
>> uninstalling IIS. Then deleting the existing config files in
>> c:\windows\system32\inetsrv\config (you will need to use an elevated
>> window to do this), and then reinstalling IIS.
>>
>> Also, install Vista SP1 (if you haven't already), as that has some fixes
>> (apparently) for some apphost.config corruption issues.
>>
>> Cheers
>> Ken
>>
>>
>> "Fresno Bob" <nospam@nospam.com> wrote in message
>> news:EC919F0D-4145-48AF-95C9-8478E0407409@microsoft.com...
>>> Hi I ugraded to Ultimate from Business Premium and IIS doesn't work any
>>> more I get a 503 error - Service Unavailable. I create an application
>>> pool and then a web site that uses it. When I go to access the page via
>>> localhost I get the 503 error and the app pool stops
>>>
>>>
>>>
>>> This is an IIS issue as it affects html pages and not just aspx. When I
>>> look in the event log I see the following error -
>>>
>>>
>>>
>>> The worker process for application pool '*******' encountered an error
>>> 'Cannot read configuration file
>>>
>>> ' trying to read global module configuration data from file
>>> '\\?\C:\Windows\system32\inetsrv\config\applicationHost.conf ig', line
>>> number '0'. Worker process startup aborted.
>>>
>>>
>>> I have tried
>>>
>>> 1. Copying the applicationHost.config from an MS website in the config
>>> file was corrupted
>>>
>>> 2. Giving the Network Service read permissions to the
>>> C:\Windows\system32\inetsrv\config folder - however I was only
>>> successful with this once - I reinstalled IIS and now it won't let me
>>> add users to the folder.
>>>
>>>
>>>
>>> This is really frustrating - I paid a lot of money for this upgrade and
>>> a lot things, which I bought it for, don't work. Can anyone help
>>> regards, Chris.
>>>
>>
>

Report this message

#3: IIS gives 503 Service Unavailable

Posted on 2008-04-18 16:02:29 by DFS

Hi I ugraded to Ultimate from Business Premium and IIS doesn't work any more
I get a 503 error - Service Unavailable. I create an application pool and
then a web site that uses it. When I go to access the page via localhost I
get the 503 error and the app pool stops



This is an IIS issue as it affects html pages and not just aspx. When I look
in the event log I see the following error -



The worker process for application pool '*******' encountered an error
'Cannot read configuration file

' trying to read global module configuration data from file
'\\?\C:\Windows\system32\inetsrv\config\applicationHost.conf ig', line number
'0'. Worker process startup aborted.


I have tried

1. Copying the applicationHost.config from an MS website in the config file
was corrupted

2. Giving the Network Service read permissions to the
C:\Windows\system32\inetsrv\config folder - however I was only successful
with this once - I reinstalled IIS and now it won't let me add users to the
folder.



This is really frustrating - I paid a lot of money for this upgrade and a
lot things, which I bought it for, don't work. Can anyone help regards,
Chris.

Report this message

#4: Re: IIS gives 503 Service Unavailable

Posted on 2008-04-18 19:20:38 by DFS

Hi thanks for the reply. I wish I would have posted here earlier. I have
just installed SP 1 and it all seems fine. So far.....

Regards, Chris.


"Ken Schaefer" <kenREMOVE@THISadOpenStatic.com> wrote in message
news:OV7snPQoIHA.3428@TK2MSFTNGP02.phx.gbl...
> There is something wrong with your applicationHost.config file. This is
> the central IIS configuration file.
>
> If you don't have a working backup of this file, you could consider
> uninstalling IIS. Then deleting the existing config files in
> c:\windows\system32\inetsrv\config (you will need to use an elevated
> window to do this), and then reinstalling IIS.
>
> Also, install Vista SP1 (if you haven't already), as that has some fixes
> (apparently) for some apphost.config corruption issues.
>
> Cheers
> Ken
>
>
> "Fresno Bob" <nospam@nospam.com> wrote in message
> news:EC919F0D-4145-48AF-95C9-8478E0407409@microsoft.com...
>> Hi I ugraded to Ultimate from Business Premium and IIS doesn't work any
>> more I get a 503 error - Service Unavailable. I create an application
>> pool and then a web site that uses it. When I go to access the page via
>> localhost I get the 503 error and the app pool stops
>>
>>
>>
>> This is an IIS issue as it affects html pages and not just aspx. When I
>> look in the event log I see the following error -
>>
>>
>>
>> The worker process for application pool '*******' encountered an error
>> 'Cannot read configuration file
>>
>> ' trying to read global module configuration data from file
>> '\\?\C:\Windows\system32\inetsrv\config\applicationHost.conf ig', line
>> number '0'. Worker process startup aborted.
>>
>>
>> I have tried
>>
>> 1. Copying the applicationHost.config from an MS website in the config
>> file was corrupted
>>
>> 2. Giving the Network Service read permissions to the
>> C:\Windows\system32\inetsrv\config folder - however I was only successful
>> with this once - I reinstalled IIS and now it won't let me add users to
>> the folder.
>>
>>
>>
>> This is really frustrating - I paid a lot of money for this upgrade and a
>> lot things, which I bought it for, don't work. Can anyone help regards,
>> Chris.
>>
>

Report this message

#5: Re: IIS gives 503 Service Unavailable

Posted on 2008-04-18 19:24:42 by DFS

Out of curiosity how do I do things like delete with an elevated privilage?
Do you mean right click on e.g. Windows Explorer and run as Administrator.


"Ken Schaefer" <kenREMOVE@THISadOpenStatic.com> wrote in message
news:OV7snPQoIHA.3428@TK2MSFTNGP02.phx.gbl...
> There is something wrong with your applicationHost.config file. This is
> the central IIS configuration file.
>
> If you don't have a working backup of this file, you could consider
> uninstalling IIS. Then deleting the existing config files in
> c:\windows\system32\inetsrv\config (you will need to use an elevated
> window to do this), and then reinstalling IIS.
>
> Also, install Vista SP1 (if you haven't already), as that has some fixes
> (apparently) for some apphost.config corruption issues.
>
> Cheers
> Ken
>
>
> "Fresno Bob" <nospam@nospam.com> wrote in message
> news:EC919F0D-4145-48AF-95C9-8478E0407409@microsoft.com...
>> Hi I ugraded to Ultimate from Business Premium and IIS doesn't work any
>> more I get a 503 error - Service Unavailable. I create an application
>> pool and then a web site that uses it. When I go to access the page via
>> localhost I get the 503 error and the app pool stops
>>
>>
>>
>> This is an IIS issue as it affects html pages and not just aspx. When I
>> look in the event log I see the following error -
>>
>>
>>
>> The worker process for application pool '*******' encountered an error
>> 'Cannot read configuration file
>>
>> ' trying to read global module configuration data from file
>> '\\?\C:\Windows\system32\inetsrv\config\applicationHost.conf ig', line
>> number '0'. Worker process startup aborted.
>>
>>
>> I have tried
>>
>> 1. Copying the applicationHost.config from an MS website in the config
>> file was corrupted
>>
>> 2. Giving the Network Service read permissions to the
>> C:\Windows\system32\inetsrv\config folder - however I was only successful
>> with this once - I reinstalled IIS and now it won't let me add users to
>> the folder.
>>
>>
>>
>> This is really frustrating - I paid a lot of money for this upgrade and a
>> lot things, which I bought it for, don't work. Can anyone help regards,
>> Chris.
>>
>

Report this message