Bookmarks

Yahoo Gmail Google Facebook Delicious Twitter Reddit Stumpleupon Myspace Digg

Search queries

nrao wwwxxx, xxxxxdup, procmail change subject header, wwwXxx not20, Wwwxxx.doks sas, linux raid resync after reboot, bind-address mysql multiple, sanibleone xxxx, ftp://192.168.100.100/, www.xxxcon

Links

XODOX
Impressum

#1: No apxs when updating PHP

Posted on 2008-04-24 23:12:33 by mechphisto

I have a FC 7 box with PHP 5.2.4 and I'm installing mcrypt. To do
that, I have to recompile PHP with the libmcrypt switches in the ./
configure.
So I downloaded the latest PHP source files, and using phpinfo() got
my current configure command (included below), took off the quotes,
added the new switches, and got an error unrelated to mcrypt:

-error-
checking for Apache 2.0 handler-module support via DSO through
APXS...

Sorry, I cannot run apxs. Possible reasons follow:

1. Perl is not installed
2. apxs was not found. Try to pass the path using --with-apxs2=/path/
to/apxs
3. Apache was not built using --enable-so (the apxs usage page is
displayed)

The output of /usr/sbin/apxs follows:
../configure: line 6669: /usr/sbin/apxs: No such file or directory
configure: error: Aborting
-end error-

I did a find and an updatedb/locate for apxs and this is all I could
find:

/var/www/manual/programs/apxs.html

Web searching for an answer all I can find are fixes to put the proper
location for apxs in the configure, but as you can see, I don't seem
to have the bin.
I also tried a "yum search apxs" and got nothing.

So, how did my PHP have apxs before if when I reconfigure now it can't
find it. And more importantly, how do I fix this?

Thanks!

../configure --build=i386-redhat-linux-gnu --host=i386-redhat-linux-gnu
--target=i386-redhat-linux-gnu --program-prefix= --prefix=/usr --exec-
prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --
datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib --
libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com
--mandir=/usr/share/man --infodir=/usr/share/info --cache-file=../
config.cache --with-libdir=lib --with-config-file-path=/etc --with-
config-file-scan-dir=/etc/php.d --disable-debug --with-pic --disable-
rpath --without-pear --with-bz2 --with-curl --with-exec-dir=/usr/bin --
with-freetype-dir=/usr --with-png-dir=/usr --enable-gd-native-ttf --
without-gdbm --with-gettext --with-gmp --with-iconv --with-jpeg-dir=/
usr --with-openssl --with-png --with-pspell --with-expat-dir=/usr --
with-pcre-regex=/usr --with-zlib --with-layout=GNU --enable-exif --
enable-ftp --enable-magic-quotes --enable-sockets --enable-sysvsem --
enable-sysvshm --enable-sysvmsg --enable-track-vars --enable-trans-sid
--enable-yp --enable-wddx --with-kerberos --enable-ucd-snmp-hack --
with-unixODBC=shared,/usr --enable-memory-limit --enable-shmop --
enable-calendar --enable-dbx --enable-dio --without-mime-magic --
without-sqlite --with-libxml-dir=/usr --with-xml --with-apxs2=/usr/
sbin/apxs --without-mysql --without-gd --without-odbc --disable-dom --
disable-dba --without-unixODBC --disable-pdo --disable-xmlreader --
disable-xmlwriter --disable-json --with-mcrypt=/usr/local/lib/ --
disable-posix-threads --enable-dynamic-loading

Report this message