Bookmarks

Yahoo Gmail Google Facebook Delicious Twitter Reddit Stumpleupon Myspace Digg

Search queries

nrao wwwxxx, xxxxxdup, procmail change subject header, wwwXxx not20, Wwwxxx.doks sas, linux raid resync after reboot, bind-address mysql multiple, sanibleone xxxx, ftp://192.168.100.100/, www.xxxcon

Links

XODOX
Impressum

#1: Bug #37411 - Threads staying in the "Sending Data" for long periods of time

Posted on 2008-10-19 15:20:10 by jiri.hlinka

------=_Part_73642_29987351.1224422410943
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

Hallo,
i've got the same problem as described in bugreport of the Bug #37411 -
Threads staying in the "Sending Data" for long periods of time (
http://bugs.mysql.com/bug.php?id=37411) with MySQL 5.0.67 on Solaris on Sun
X4200 M2.
I'm not able to bypass the problem by setting
innodb_thread_concurrency=1
because application running above the database has bigger frequency of
queries than server can supply. Im not able to set value higher than "1",
because queries will be very slow (as result of the bug). AFAIK there are
only two options:
1) apply a patch
2) upgrade to MySQL

I wolud like to ask you, if there is any patch solving the problem (there
isnt any info on bug's page mentioned above), or if upgrade to MySQL version
5.1 will solve the problem?

Thank you very much for any ideas,
Jirka

PS: MySQL configuration is quiet good, as its just innodb tables and
configuration equals (almost) to the one described in my-innodb-heavy-4G.cnf
(I have 8GB RAM).

------=_Part_73642_29987351.1224422410943--

Report this message

#2: Re: Bug #37411 - Threads staying in the "Sending Data" for longperiods of time

Posted on 2008-10-19 17:41:44 by Valeriy Kravchuk

Hi JiÃÂí,

> i've got the same problem as described in bugreport of the Bug #374=
11 -
> Threads staying in the "Sending Data" for long periods of time (
> http://bugs.mysql.com/bug.php?id=3D37411) with MySQL 5.0.67 on Sola=
ris on Sun
> X4200 M2.
> I'm not able to bypass the problem by setting
> innodb_thread_concurrency=3D1
> because application running above the database has bigger frequency=
of
> queries than server can supply. Im not able to set value higher tha=
n "1",
> because queries will be very slow (as result of the bug). AFAIK th=
ere are
> only two options:
> 1) apply a patch
> 2) upgrade to MySQL

I do not know any specific patch, as the reason of that bug is still =
not=20
clear. Please, send the results of EXPLAIN for the queries that becom=
es=20
slow and send your my.cnf.

Please, upload also (to the bug #37411) the results of SHOW MUTEX STA=
TUS.

I think upgrade to 5.1.28 worth a try. I know cases when it helped.

> PS: MySQL configuration is quiet good, as its just innodb tables an=
d
> configuration equals (almost) to the one described in my-innodb-hea=
vy-4G.cnf
> (I have 8GB RAM).

This does not make your configuration automagically optimal for your=
=20
environment.

Best regards,
--=20
Valeriy Kravchuk, MySQL Principal Support Engineer
Sun Microsystems, Inc.
Kiev, Ukraine, www.sun.com/mysql


--
MySQL Bugs Mailing List
For list archives: http://lists.mysql.com/bugs
To unsubscribe: http://lists.mysql.com/bugs?unsub=3Dgcdmb-bugs@m.gmane.org

Report this message