Bookmarks

Yahoo Gmail Google Facebook Delicious Twitter Reddit Stumpleupon Myspace Digg

Search queries

htaccess multiple authuserfile, www.xxx.con, www.xxxcon, wwwxxx100www, www...xxxcon, www.xxxcon, error 1025 mysql errno:150, xxx.con, w.w.w.xxxcon, www,xxx.con

Links

XODOX
Impressum

#1: Getting::message type 0x43 arrived from server while idle

Posted on 2009-12-23 13:36:21 by Mohammed Rashid

--000e0cd56c32e4a9a9047b64915e
Content-Type: text/plain; charset=ISO-8859-1

Hi All,

I am using the postgres database in one of my project.
I am getting "message type 0x43 arrived from server while idle" messages
while querying the database and getting erroneous results.

I am using libpq library for querying database.
I am having two different processes accessing the same database.

I am hoping to read soon.

Regards,
Rashid

--000e0cd56c32e4a9a9047b64915e
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

<br>Hi All,<br><br>I am using the postgres database in one of my project.<b=
r>=A0I am getting &quot;message type 0x43 arrived from server while idle&qu=
ot;=A0 messages<br>=A0while querying the database and getting erroneous res=
ults.<br>
<br>I am using libpq library for querying database. <br>I am having two dif=
ferent processes accessing the same database.<br><br>I am hoping to read so=
on.<br><br>Regards,<br>Rashid<br><br>

--000e0cd56c32e4a9a9047b64915e--

Report this message

#2: Re: Getting::message type 0x43 arrived from server while idle

Posted on 2009-12-30 21:36:17 by Tom Lane

Mohammed Rashid <mail4rashid@gmail.com> writes:
> I am getting "message type 0x43 arrived from server while idle" messages
> while querying the database and getting erroneous results.

> I am using libpq library for querying database.
> I am having two different processes accessing the same database.

I'll bet what you're really doing is using two different threads within
the same process, and trying to have those threads concurrently issue
commands through the same connection (same PGconn object). This does
not work. Give each thread its own connection. Also read
http://www.postgresql.org/docs/8.4/static/libpq-threading.ht ml

regards, tom lane

--
Sent via pgsql-admin mailing list (pgsql-admin@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-admin

Report this message

#3: Re: Getting::message type 0x43 arrived from server

Posted on 2009-12-30 22:24:23 by Kevin Grittner

Mohammed Rashid <mail4rashid@gmail.com> wrote:

> I am getting "message type 0x43 arrived from server while idle"
> messages while querying the database and getting erroneous
> results.
>
> I am using libpq library for querying database.
> I am having two different processes accessing the same database.

More details would help. For some ideas on what might enable us to
help you, please check the "Things you need to mention" section at:

http://wiki.postgresql.org/wiki/Guide_to_reporting_problems

-Kevin

--
Sent via pgsql-admin mailing list (pgsql-admin@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-admin

Report this message

#4: Re: Getting::message type 0x43 arrived from server while idle

Posted on 2009-12-30 23:06:55 by John DeSoi

On Dec 23, 2009, at 7:36 AM, Mohammed Rashid wrote:

> I am using the postgres database in one of my project.
> I am getting "message type 0x43 arrived from server while idle" messages
> while querying the database and getting erroneous results.
>
> I am using libpq library for querying database.
> I am having two different processes accessing the same database.

Are you using a different connection for each process?




John DeSoi, Ph.D.





--
Sent via pgsql-admin mailing list (pgsql-admin@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-admin

Report this message