Bookmarks

Yahoo Gmail Google Facebook Delicious Twitter Reddit Stumpleupon Myspace Digg

Search queries

bind-address mysql multiple, sanibleone xxxx, ftp://192.168.100.100/, www.xxxcon, which comes first ob_start or session, wwwxxx/58/2010, xxxxdup, xxxxdup, mailx informatii, should producers of software-based services, such as atms, be held liable for economic injuries suffered when their systems fail?

Links

XODOX
Impressum

#1: Error while setting up streaming replication, postgres 9.0-beta 4

Posted on 2010-08-23 21:07:54 by fazool mein

--e0cb4e6ff629b30586048e825db6
Content-Type: text/plain; charset=ISO-8859-1

Hello everyone,

OS = Linux Suse, sles 11, 64-bit
Postgres version = 9.0 beta-4

I'm trying to test streaming replication. I set up a primary and secondary.
The primary starts normal, but when I start the standby, it doesn't start
up. The log looks like this:

LOG: database system was interrupted while in recovery at log time
2010-08-23 13:30:43 EDT
HINT: If this has occurred more than once some data might be corrupted and
you might need to choose an earlier recovery target.
LOG: entering standby mode
WARNING: WAL was generated with wal_level=minimal, data may be missing
HINT: This happens if you temporarily set wal_level=minimal without taking
a new base backup.
FATAL: hot standby is not possible because wal_level was not set to
"hot_standby" on the master server
HINT: Either set wal_level to "hot_standby" on the master, or turn off
hot_standby here.
LOG: startup process (PID 5875) exited with exit code 1
LOG: aborting startup due to startup process failure


Note that I have checked multiple times that 'wal_level' is set to
'hot_standby' on the primary, and the secondary has correct connection
information to the primary in 'resolve.conf'.

Any pointers?

Thanks.

--e0cb4e6ff629b30586048e825db6
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Hello everyone,<br><br>OS =3D Linux Suse, sles 11, 64-bit<br>Postgres versi=
on =3D 9.0 beta-4<br><br>I&#39;m trying to test streaming replication. I se=
t up a primary and secondary. The primary starts normal, but when I start t=
he standby, it doesn&#39;t start up. The log looks like this:<br>
<br>LOG:=A0 database system was interrupted while in recovery at log time 2=
010-08-23 13:30:43 EDT<br>HINT:=A0 If this has occurred more than once some=
data might be corrupted and you might need to choose an earlier recovery t=
arget.<br>
LOG:=A0 entering standby mode<br>WARNING:=A0 WAL was generated with wal_lev=
el=3Dminimal, data may be missing<br>HINT:=A0 This happens if you temporari=
ly set wal_level=3Dminimal without taking a new base backup.<br>FATAL:=A0 h=
ot standby is not possible because wal_level was not set to &quot;hot_stand=
by&quot; on the master server<br>
HINT:=A0 Either set wal_level to &quot;hot_standby&quot; on the master, or =
turn off hot_standby here.<br>LOG:=A0 startup process (PID 5875) exited wit=
h exit code 1<br>LOG:=A0 aborting startup due to startup process failure<br=
><br>
<br>Note that I have checked multiple times that &#39;wal_level&#39; is set=
to &#39;hot_standby&#39; on the primary, and the secondary has correct con=
nection information to the primary in &#39;resolve.conf&#39;.<br><br>Any po=
inters?<br>
<br>Thanks.<br><br><br>

--e0cb4e6ff629b30586048e825db6--

Report this message

#2: Re: Error while setting up streaming replication, postgres 9.0-beta 4

Posted on 2010-08-23 21:17:55 by Tom Lane

fazool mein <fazoolmein@gmail.com> writes:
> I'm trying to test streaming replication. I set up a primary and secondary.
> The primary starts normal, but when I start the standby, it doesn't start
> up. The log looks like this:

> LOG: database system was interrupted while in recovery at log time
> 2010-08-23 13:30:43 EDT
> HINT: If this has occurred more than once some data might be corrupted and
> you might need to choose an earlier recovery target.
> LOG: entering standby mode
> WARNING: WAL was generated with wal_level=minimal, data may be missing
> HINT: This happens if you temporarily set wal_level=minimal without taking
> a new base backup.
> FATAL: hot standby is not possible because wal_level was not set to
> "hot_standby" on the master server
> HINT: Either set wal_level to "hot_standby" on the master, or turn off
> hot_standby here.
> LOG: startup process (PID 5875) exited with exit code 1
> LOG: aborting startup due to startup process failure


> Note that I have checked multiple times that 'wal_level' is set to
> 'hot_standby' on the primary,

You need to do that *before* taking your base backup. The WARNING above
indicates that the backup was taken with an inadequate wal_level
setting.

regards, tom lane

--
Sent via pgsql-admin mailing list (pgsql-admin@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-admin

Report this message

#3: Re: Error while setting up streaming replication, postgres9.0-beta 4

Posted on 2010-08-23 21:57:34 by fazool mein

--0016e647ec6e469797048e830f02
Content-Type: text/plain; charset=ISO-8859-1

Great! I made the base backup again as you said, and its working now.
Thanks.


On Mon, Aug 23, 2010 at 12:17 PM, Tom Lane <tgl@sss.pgh.pa.us> wrote:

> fazool mein <fazoolmein@gmail.com> writes:
> > I'm trying to test streaming replication. I set up a primary and
> secondary.
> > The primary starts normal, but when I start the standby, it doesn't start
> > up. The log looks like this:
>
> > LOG: database system was interrupted while in recovery at log time
> > 2010-08-23 13:30:43 EDT
> > HINT: If this has occurred more than once some data might be corrupted
> and
> > you might need to choose an earlier recovery target.
> > LOG: entering standby mode
> > WARNING: WAL was generated with wal_level=minimal, data may be missing
> > HINT: This happens if you temporarily set wal_level=minimal without
> taking
> > a new base backup.
> > FATAL: hot standby is not possible because wal_level was not set to
> > "hot_standby" on the master server
> > HINT: Either set wal_level to "hot_standby" on the master, or turn off
> > hot_standby here.
> > LOG: startup process (PID 5875) exited with exit code 1
> > LOG: aborting startup due to startup process failure
>
>
> > Note that I have checked multiple times that 'wal_level' is set to
> > 'hot_standby' on the primary,
>
> You need to do that *before* taking your base backup. The WARNING above
> indicates that the backup was taken with an inadequate wal_level
> setting.
>
> regards, tom lane
>

--0016e647ec6e469797048e830f02
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Great! I made the base backup again as you said, and its working now.<br>Th=
anks.<br><br><br><div class=3D"gmail_quote">On Mon, Aug 23, 2010 at 12:17 P=
M, Tom Lane <span dir=3D"ltr">&lt;<a href=3D"mailto:tgl@sss.pgh.pa.us">tgl@=
sss.pgh.pa.us</a>&gt;</span> wrote:<br>
<blockquote class=3D"gmail_quote" style=3D"margin: 0pt 0pt 0pt 0.8ex; borde=
r-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;"><div class=3D"im"=
>fazool mein &lt;<a href=3D"mailto:fazoolmein@gmail.com">fazoolmein@gmail.c=
om</a>&gt; writes:<br>

&gt; I&#39;m trying to test streaming replication. I set up a primary and s=
econdary.<br>
&gt; The primary starts normal, but when I start the standby, it doesn&#39;=
t start<br>
&gt; up. The log looks like this:<br>
<br>
&gt; LOG: =A0database system was interrupted while in recovery at log time<=
br>
&gt; 2010-08-23 13:30:43 EDT<br>
&gt; HINT: =A0If this has occurred more than once some data might be corrup=
ted and<br>
&gt; you might need to choose an earlier recovery target.<br>
&gt; LOG: =A0entering standby mode<br>
&gt; WARNING: =A0WAL was generated with wal_level=3Dminimal, data may be mi=
ssing<br>
&gt; HINT: =A0This happens if you temporarily set wal_level=3Dminimal witho=
ut taking<br>
&gt; a new base backup.<br>
&gt; FATAL: =A0hot standby is not possible because wal_level was not set to=
<br>
&gt; &quot;hot_standby&quot; on the master server<br>
&gt; HINT: =A0Either set wal_level to &quot;hot_standby&quot; on the master=
, or turn off<br>
&gt; hot_standby here.<br>
&gt; LOG: =A0startup process (PID 5875) exited with exit code 1<br>
&gt; LOG: =A0aborting startup due to startup process failure<br>
<br>
<br>
&gt; Note that I have checked multiple times that &#39;wal_level&#39; is se=
t to<br>
&gt; &#39;hot_standby&#39; on the primary,<br>
<br>
</div>You need to do that *before* taking your base backup. =A0The WARNING =
above<br>
indicates that the backup was taken with an inadequate wal_level<br>
setting.<br>
<br>
=A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0regards, tom lane<br>
</blockquote></div><br>

--0016e647ec6e469797048e830f02--

Report this message