Bookmarks

Yahoo Gmail Google Facebook Delicious Twitter Reddit Stumpleupon Myspace Digg

Search queries

www.webdp.net, Event 9 IIS log failed to write entry, wwwxxx jeffs, Catastrophic failure Unexpected method call sequence. 0x8000ffff (-2147418113)., ksh lock a file, [unixODBC][Driver Manager]Driver's SQLAllocHandle on SQL_HANDLE_DBC failed, sed: -e expression #1, char 1: unterminated address regex, procmail + change subject, w2ksp4.exe download, /proc/kallsyms format

Links

XODOX
Impressum

#1: Re: Ubuntu and mod_perl

Posted on 2011-05-17 22:57:50 by wrowe

On 5/17/2011 3:39 PM, Tom Kane wrote:
> I'm still a little new at responding to mail lists. Here is an email that I sent directly in a reply to Marco. I thought that it should be shared:
>
> Marco,
>
> I had to do the following just the other day:
>
> sudo ln -sf /usr/lib/libperl.so.5.10.1 /usr/lib/libperl.so
>
> That got me over the hurdle that occurred because of the missing symbolic link to perl. I also had to do the following:
>
> sudo ln -sf /usr/lib/libgdbm.so.3.0.0 /usr/lib/libgdbm.so
>
> The libgdbm issue actually occurred prior to the perl problem.
>
> I hope this helps. I am now trying to find the settings for mod_perl in the /etc/apache2 configuration. My startup.pl file returns an error message that I can't use 'use'.

Tom, it seems you are missing gdbm-devel and perl-devel packages. To get
the appropriate .a/.so/.h files, you usually have to add -devel (or -dev)
flavors of various system components to build new software against them.

Report this message

#2: Re: Ubuntu and mod_perl

Posted on 2011-05-17 23:05:58 by aw

Tom Kane wrote:
> I'm still a little new at responding to mail lists. Here is an email that I sent directly in a reply to Marco. I thought that it should be shared:
>
> Marco,
>
> I had to do the following just the other day:
>
> sudo ln -sf /usr/lib/libperl.so.5.10.1 /usr/lib/libperl.so
>
> That got me over the hurdle that occurred because of the missing symbolic link to perl. I also had to do the following:
>
> sudo ln -sf /usr/lib/libgdbm.so.3.0.0 /usr/lib/libgdbm.so
>
> The libgdbm issue actually occurred prior to the perl problem.
>
> I hope this helps. I am now trying to find the settings for mod_perl in the /etc/apache2 configuration. My startup.pl file returns an error message that I can't use 'use'.
>
> Tom
>

Maybe as a tip to both Tom and Marco :

It all depends if your focus is on installing apache and perl and mod_perl, or rather on
just using them to achieve another main goal.

But if your main aim is not the installation of apache and mod_perl, then I would
recommend to both, to use the software packaging system of your respective flavors of
Linux, to install Apache, perl and mod_perl using these pre-packaged versions.
That will take just a few minutes, and will work without having to spend hours resolving
dependencies, fixing missing links (maybe wrongly), and creating your own startup scripts.

And the hours you save will then be available for achieving your main goal.

Report this message

#3: Re: Ubuntu and mod_perl

Posted on 2011-05-17 23:07:52 by Fred Moyer

On Tue, May 17, 2011 at 2:05 PM, Andr=E9 Warnier <aw@ice-sa.com> wrote:
> But if your main aim is not the installation of apache and mod_perl, then=
I
> would recommend to both, to use the software packaging system of your
> respective flavors of Linux, to install Apache, perl and mod_perl using
> these pre-packaged versions.
> That will take just a few minutes, and will work without having to spend
> hours resolving dependencies, fixing missing links (maybe wrongly), and
> creating your own startup scripts.
>
> And the hours you save will then be available for achieving your main goa=
l.

This, a thousand times this.

Report this message

#4: Ubuntu and mod_perl

Posted on 2011-05-18 00:05:54 by Tom Kane

I'm still a little new at responding to mail lists. Here is an email that I sent directly in a reply to Marco. I thought that it should be shared:

Marco,

I had to do the following just the other day:

sudo ln -sf /usr/lib/libperl.so.5.10.1 /usr/lib/libperl.so

That got me over the hurdle that occurred because of the missing symbolic link to perl. I also had to do the following:

sudo ln -sf /usr/lib/libgdbm.so.3.0.0 /usr/lib/libgdbm.so

The libgdbm issue actually occurred prior to the perl problem.

I hope this helps. I am now trying to find the settings for mod_perl in the /etc/apache2 configuration. My startup.pl file returns an error message that I can't use 'use'.

Tom

Report this message