Bookmarks

Yahoo Gmail Google Facebook Delicious Twitter Reddit Stumpleupon Myspace Digg

Search queries

w2ksp4.exe, WwwxxXdbf, procmail "FROM_MAILER" patch, Use of assignment to $[ is deprecated at /usr/local/sbin/apxs line 86. , wwwxxx vim, mysql closing table and opening table, 800c5000, setgid operation not permitted, pciehp: acpi_pciehprm on IBM, WWWXXX.DBF

Links

XODOX
Impressum

#1: Re: mysqldump: Got error: 1017: Can"t find file: "./ssconsole/ss_requestmaster.frm"(errno: 24) when

Posted on 2011-09-24 17:26:06 by sureshkumarilu

--20cf300e54476d7eb304adb18bf6
Content-Type: text/plain; charset=ISO-8859-1

Hello Shafi,

Adding to Prabhat alternatives, you can use --force to the mysqldump command
to ignore the errors and continue taking backup.

Regarding the error, we need to check whether the table is present or not
and the engine type specifically.

Thanks
Suresh Kuna

On Sat, Sep 24, 2011 at 3:31 AM, Prabhat Kumar <aim.prabhat@gmail.com>wrote:

> correct. mysqldump by default has --lock-tables enabled, which means it
> tries to lock all tables to be dumped before starting the dump. And doing
> LOCK TABLES t1, t2, ... for really big number of tables will inevitably
> exhaust all available file descriptors, as LOCK needs all tables to be
> opened.
>
> Workarounds: --skip-lock-tables will disable such a locking completely.
> Alternatively, --lock-all-tables will make mysqldump to use FLUSH TABLES
> WITH READ LOCK which locks all tables in all databases (without opening
> them). In this case mysqldump will automatically disable --lock-tables
> because it makes no sense when --lock-all-tables is used. or try with add
> --single_transaction to your mysqldump command
>
> On Fri, Sep 23, 2011 at 9:49 AM, Dan Nelson <dnelson@allantgroup.com>
> wrote:
>
> > In the last episode (Sep 23), Shafi AHMED said:
> > > I have a mysql database of 200G size and the backup fails due to the
> > foll.
> > > Issue.
> > >
> > > mysqldump: Got error: 1017: Can't find file:
> > > './ssconsole/ss_requestmaster.frm' (errno: 24) when using LOCK TABLES
> > >
> > > Can someone assist pls.?
> >
> > $ perror 24
> > OS error code 24: Too many open files
> >
> > You need to bump up the max files limit in your OS. It may be defaulting
> > to
> > a small number like 1024. If you can't change that limit, edit your
> my.cnf
> > and lower the table_open_cache number. You'll lose performance though,
> > since mysql will have to stop accessing some tables to open others.
> >
> > http://dev.mysql.com/doc/refman/5.5/en/not-enough-file-handl es.html
> >
> > --
> > Dan Nelson
> > dnelson@allantgroup.com
> >
> > --
> > MySQL General Mailing List
> > For list archives: http://lists.mysql.com/mysql
> > To unsubscribe:
> > http://lists.mysql.com/mysql?unsub=aim.prabhat@gmail.com
> >
> >
>
>
> --
> Best Regards,
>
> Prabhat Kumar
> MySQL DBA
>
> My Blog: http://adminlinux.blogspot.com
> My LinkedIn: http://www.linkedin.com/in/profileprabhat
>



--
Thanks
Suresh Kuna
MySQL DBA

--20cf300e54476d7eb304adb18bf6--

Report this message

#2: RE: mysqldump: Got error: 1017: Can"t find file: "./ssconsole/ss_requestmaster.frm" (errno: 24) when

Posted on 2011-09-26 07:07:09 by Shafi AHMED

------=_NextPart_000_02B5_01CC7C38.3EC36F70
Content-Type: text/plain;
charset="us-ascii"
Content-Transfer-Encoding: 7bit

Thanks dear everyone for sharing your views!

Let me try the workarounds and keep you posted.



Best Rgs,

Shafi AHMED





_____

From: Suresh Kuna [mailto:sureshkumarilu@gmail.com]
Sent: Saturday, September 24, 2011 8:56 PM
To: Prabhat Kumar
Cc: Dan Nelson; Shafi AHMED; mysql@lists.mysql.com
Subject: Re: mysqldump: Got error: 1017: Can't find file:
'./ssconsole/ss_requestmaster.frm' (errno: 24) when using LOCK TABLES



Hello Shafi,

Adding to Prabhat alternatives, you can use --force to the mysqldump command
to ignore the errors and continue taking backup.

Regarding the error, we need to check whether the table is present or not
and the engine type specifically.

Thanks
Suresh Kuna

On Sat, Sep 24, 2011 at 3:31 AM, Prabhat Kumar <aim.prabhat@gmail.com>
wrote:

correct. mysqldump by default has --lock-tables enabled, which means it
tries to lock all tables to be dumped before starting the dump. And doing
LOCK TABLES t1, t2, ... for really big number of tables will inevitably
exhaust all available file descriptors, as LOCK needs all tables to be
opened.

Workarounds: --skip-lock-tables will disable such a locking completely.
Alternatively, --lock-all-tables will make mysqldump to use FLUSH TABLES
WITH READ LOCK which locks all tables in all databases (without opening
them). In this case mysqldump will automatically disable --lock-tables
because it makes no sense when --lock-all-tables is used. or try with add
--single_transaction to your mysqldump command


On Fri, Sep 23, 2011 at 9:49 AM, Dan Nelson <dnelson@allantgroup.com> wrote:

> In the last episode (Sep 23), Shafi AHMED said:
> > I have a mysql database of 200G size and the backup fails due to the
> foll.
> > Issue.
> >
> > mysqldump: Got error: 1017: Can't find file:
> > './ssconsole/ss_requestmaster.frm' (errno: 24) when using LOCK TABLES
> >
> > Can someone assist pls.?
>
> $ perror 24
> OS error code 24: Too many open files
>
> You need to bump up the max files limit in your OS. It may be defaulting
> to
> a small number like 1024. If you can't change that limit, edit your
my.cnf
> and lower the table_open_cache number. You'll lose performance though,
> since mysql will have to stop accessing some tables to open others.
>
> http://dev.mysql.com/doc/refman/5.5/en/not-enough-file-handl es.html
>
> --
> Dan Nelson
> dnelson@allantgroup.com
>
> --
> MySQL General Mailing List
> For list archives: http://lists.mysql.com/mysql
> To unsubscribe:

> http://lists.mysql.com/mysql?unsub=aim.prabhat@gmail.com
>
>


--
Best Regards,

Prabhat Kumar
MySQL DBA

My Blog: http://adminlinux.blogspot.com
My LinkedIn: http://www.linkedin.com/in/profileprabhat




--
Thanks
Suresh Kuna
MySQL DBA




Get your world in your inbox!

Mail, widgets, documents, spreadsheets, organizer and much more with your Sifymail WIYI id!
Log on to http://www.sify.com

********** DISCLAIMER **********
Information contained and transmitted by this E-MAIL is proprietary to
Sify Technologies Limited and is intended for use only by the individual or entity to
which it is addressed, and may contain information that is privileged,
confidential or exempt from disclosure under applicable law. If this is a
forwarded message, the content of this E-MAIL may not have been sent with
the authority of the Company. If you are not the intended recipient, an
agent of the intended recipient or a person responsible for delivering the
information to the named recipient, you are notified that any use,
distribution, transmission, printing, copying or dissemination of this
information in any way or in any manner is strictly prohibited. If you have
received this communication in error, please delete this mail & notify us
immediately at admin@sifycorp.com

------=_NextPart_000_02B5_01CC7C38.3EC36F70--

Report this message