Bookmarks

Yahoo Gmail Google Facebook Delicious Twitter Reddit Stumpleupon Myspace Digg

Search queries



Links

Issociate
Impressum

#1: Help - CGI Error on IIS6

Posted on 2004-10-04 13:49:55 by romeo

Hi all,

I've searched in Google, Google groups and the ASPN Mailing List and have
been looking for answers for days to get my cgi scripts to work in IIS6.
When I try to load a .pl file in my web browser, I get the following error:

CGI Error
The specified CGI application misbehaved by not returning a complete set
of HTTP headers.

We're running a Windows 2003 Standard edition server with IIS6 and installed
ActivePerl 5.8.4.810 via the MSI with following settings:

In the configuration I have .pl listed under extensions which is Associate
with c:\Perl\Bin\Perl.exe "%s" %s and the verbs are listed as GET, HEAD,
POST the boxes are checked for both Script Engine and Verify that file exists.
(This is inserted by the ActivePerl installation process.)

Even though we ?allow? the extension in the IIS under 'WebService Extensions'.

Under execute permissions I have Scripts and Executables

Under the Directory security tab in the Authentication and access control
properties I have the Enable anonymous access checked and I am using the
IUSR_ account and correct password.

It seems to be a configuration problem, because the script works perfectly
in the command line.

I hope someone can help me
R.



_______________________________________________
ActivePerl mailing list
ActivePerl@listserv.ActiveState.com
To unsubscribe: http://listserv.ActiveState.com/mailman/mysubs

Report this message

Mr Ad

Google

#2: Re: Help - CGI Error on IIS6

Posted on 2004-10-04 14:41:43 by active

When i have this problem, is becuase my script
dont sends the
print "Content-type: text/html\n\n";
first line.
Mybe there is the problem.



----- Original Message -----
From:
To:
Sent: Monday, October 04, 2004 7:49 AM
Subject: Help - CGI Error on IIS6


> Hi all,
>
> I've searched in Google, Google groups and the ASPN Mailing List and have
> been looking for answers for days to get my cgi scripts to work in IIS6.
> When I try to load a .pl file in my web browser, I get the following
error:
>
> CGI Error
> The specified CGI application misbehaved by not returning a complete set
> of HTTP headers.
>
> We're running a Windows 2003 Standard edition server with IIS6 and
installed
> ActivePerl 5.8.4.810 via the MSI with following settings:
>
> In the configuration I have .pl listed under extensions which is Associate
> with c:\Perl\Bin\Perl.exe "%s" %s and the verbs are listed as GET, HEAD,
> POST the boxes are checked for both Script Engine and Verify that file
exists.
> (This is inserted by the ActivePerl installation process.)
>
> Even though we ?allow? the extension in the IIS under 'WebService
Extensions'.
>
> Under execute permissions I have Scripts and Executables
>
> Under the Directory security tab in the Authentication and access control
> properties I have the Enable anonymous access checked and I am using the
> IUSR_ account and correct password.
>
> It seems to be a configuration problem, because the script works perfectly
> in the command line.
>
> I hope someone can help me
> R.
>
>
>
> _______________________________________________
> ActivePerl mailing list
> ActivePerl@listserv.ActiveState.com
> To unsubscribe: http://listserv.ActiveState.com/mailman/mysubs
>
>

_______________________________________________
ActivePerl mailing list
ActivePerl@listserv.ActiveState.com
To unsubscribe: http://listserv.ActiveState.com/mailman/mysubs

Report this message

#3: Re: Help - CGI Error on IIS6

Posted on 2004-10-04 19:56:35 by Jeff Griffiths

a more 'correct' approach to writing a Perl CGI script is to use the CGI
module:

# start code

use strict;
use CGI;

my $page = new CGI;

# print header and start the markup output

print $page->header( "text/html" );
print $page->start_html( "hello from perl cgi!" );
print $page->h2("hello dave...");
print $page->end_html;

# end code

cheers, JeffG

yop=me wrote:
> When i have this problem, is becuase my script
> dont sends the
> print "Content-type: text/html\n\n";
> first line.
> Mybe there is the problem.
>
>
>
> ----- Original Message -----
> From:
> To:
> Sent: Monday, October 04, 2004 7:49 AM
> Subject: Help - CGI Error on IIS6
>
>
>
>>Hi all,
>>
>>I've searched in Google, Google groups and the ASPN Mailing List and have
>>been looking for answers for days to get my cgi scripts to work in IIS6.
>>When I try to load a .pl file in my web browser, I get the following
>
> error:
>
>>CGI Error
>>The specified CGI application misbehaved by not returning a complete set
>>of HTTP headers.
>>
>>We're running a Windows 2003 Standard edition server with IIS6 and
>
> installed
>
>>ActivePerl 5.8.4.810 via the MSI with following settings:
>>
>>In the configuration I have .pl listed under extensions which is Associate
>>with c:\Perl\Bin\Perl.exe "%s" %s and the verbs are listed as GET, HEAD,
>>POST the boxes are checked for both Script Engine and Verify that file
>
> exists.
>
>>(This is inserted by the ActivePerl installation process.)
>>
>>Even though we ?allow? the extension in the IIS under 'WebService
>
> Extensions'.
>
>>Under execute permissions I have Scripts and Executables
>>
>>Under the Directory security tab in the Authentication and access control
>>properties I have the Enable anonymous access checked and I am using the
>>IUSR_ account and correct password.
>>
>>It seems to be a configuration problem, because the script works perfectly
>>in the command line.
>>
>>I hope someone can help me
>>R.
>>
>>
>>
>>_______________________________________________
>>ActivePerl mailing list
>>ActivePerl@listserv.ActiveState.com
>>To unsubscribe: http://listserv.ActiveState.com/mailman/mysubs
>>
>>
>
>
> _______________________________________________
> ActivePerl mailing list
> ActivePerl@listserv.ActiveState.com
> To unsubscribe: http://listserv.ActiveState.com/mailman/mysubs
_______________________________________________
ActivePerl mailing list
ActivePerl@listserv.ActiveState.com
To unsubscribe: http://listserv.ActiveState.com/mailman/mysubs

Report this message

#4: Re: Help - CGI Error on IIS6

Posted on 2004-10-04 20:48:48 by active

could you please asociate this question
whit the question asked by romeo@pop.agri.ch


----- Original Message -----
From: "Jeff Griffiths"
To: "yop=me"
Cc:
Sent: Monday, October 04, 2004 1:56 PM
Subject: Re: Help - CGI Error on IIS6


> a more 'correct' approach to writing a Perl CGI script is to use the CGI
> module:
>
> # start code
>
> use strict;
> use CGI;
>
> my $page = new CGI;
>
> # print header and start the markup output
>
> print $page->header( "text/html" );
> print $page->start_html( "hello from perl cgi!" );
> print $page->h2("hello dave...");
> print $page->end_html;
>
> # end code
>
> cheers, JeffG
>
> yop=me wrote:
> > When i have this problem, is becuase my script
> > dont sends the
> > print "Content-type: text/html\n\n";
> > first line.
> > Mybe there is the problem.
> >
> >
> >
> > ----- Original Message -----
> > From:
> > To:
> > Sent: Monday, October 04, 2004 7:49 AM
> > Subject: Help - CGI Error on IIS6
> >
> >
> >
> >>Hi all,
> >>
> >>I've searched in Google, Google groups and the ASPN Mailing List and
have
> >>been looking for answers for days to get my cgi scripts to work in IIS6.
> >>When I try to load a .pl file in my web browser, I get the following
> >
> > error:
> >
> >>CGI Error
> >>The specified CGI application misbehaved by not returning a complete set
> >>of HTTP headers.
> >>
> >>We're running a Windows 2003 Standard edition server with IIS6 and
> >
> > installed
> >
> >>ActivePerl 5.8.4.810 via the MSI with following settings:
> >>
> >>In the configuration I have .pl listed under extensions which is
Associate
> >>with c:\Perl\Bin\Perl.exe "%s" %s and the verbs are listed as GET, HEAD,
> >>POST the boxes are checked for both Script Engine and Verify that file
> >
> > exists.
> >
> >>(This is inserted by the ActivePerl installation process.)
> >>
> >>Even though we ?allow? the extension in the IIS under 'WebService
> >
> > Extensions'.
> >
> >>Under execute permissions I have Scripts and Executables
> >>
> >>Under the Directory security tab in the Authentication and access
control
> >>properties I have the Enable anonymous access checked and I am using the
> >>IUSR_ account and correct password.
> >>
> >>It seems to be a configuration problem, because the script works
perfectly
> >>in the command line.
> >>
> >>I hope someone can help me
> >>R.
> >>
> >>
> >>
> >>_______________________________________________
> >>ActivePerl mailing list
> >>ActivePerl@listserv.ActiveState.com
> >>To unsubscribe: http://listserv.ActiveState.com/mailman/mysubs
> >>
> >>
> >
> >
> > _______________________________________________
> > ActivePerl mailing list
> > ActivePerl@listserv.ActiveState.com
> > To unsubscribe: http://listserv.ActiveState.com/mailman/mysubs
>
>

_______________________________________________
ActivePerl mailing list
ActivePerl@listserv.ActiveState.com
To unsubscribe: http://listserv.ActiveState.com/mailman/mysubs

Report this message

#5: AW: Re: Help - CGI Error on IIS6

Posted on 2004-10-05 10:10:41 by romeo

Hello yop-me,

First of all thank you very for your help. Following my Code. Do you know
where the fault is?

#!/usr/bin/perl

if ($0 =~ /(.*)\/[^\/]*$/) { push (@INC, "$1"); }
if ($0 =~ /(.*)\\[^\\]*$/) { push (@INC, "$1"); }
use site_lowlevel;
}
use site_lib;
use site_dlib;
use site_config;
use site_iolib;
use File::Find;
use site_form_lib;
use site_createlib;

%META_META = ();
@search_fields = ();
$Block_Count = 0; # A 'Block' is until the next CLEARLIST so each READDIR
only
$TIME = time; # CAPS means current time! c.k.

&active_finddate ($TIME);
$YEAR = $year;
$FULLYEAR = $fullyear;
$MON = $mon;
$MONAT = $monat;
$MDAY = $mday;
$DAYOFWEEK = $dayofweek;
$SEC = $sec;
$HOUR = $hour;
$MIN = $min;

$savepage_string = ""; # if you want to make
$taker_count = -1;

$basepath = "$SYSTEM_CONF{'DOCUMENT-ROOT'}";
$path = "$SYSTEM_CONF{'SITE-DIR'}";

%FORM = DecodeFormData (); # formulare auswerten

@cookie_fields = split (/\,/, $ENV{'HTTP_COOKIE'});
&split_cookie_fields; # Cookies auswerten
$checkfile = "indigo.htms"; # do not display this file

print "Content-Type: text/html\n";
$level = "";
undef %YET_DONE;
.....

Sebastian



>-- Originalnachricht --
>From: "yop=me"
>To:
>Date: Mon, 4 Oct 2004 08:41:43 -0400
>Subject: Re: Help - CGI Error on IIS6
>
>
>When i have this problem, is becuase my script
>dont sends the
>print "Content-type: text/html\n\n";
>first line.
>Mybe there is the problem.
>
>
>
>----- Original Message -----
>From:
>To:
>Sent: Monday, October 04, 2004 7:49 AM
>Subject: Help - CGI Error on IIS6
>
>
>> Hi all,
>>
>> I've searched in Google, Google groups and the ASPN Mailing List and
have
>> been looking for answers for days to get my cgi scripts to work in IIS6.
>> When I try to load a .pl file in my web browser, I get the following
>error:
>>
>> CGI Error
>> The specified CGI application misbehaved by not returning a complete
set
>> of HTTP headers.
>>
>> We're running a Windows 2003 Standard edition server with IIS6 and
>installed
>> ActivePerl 5.8.4.810 via the MSI with following settings:
>>
>> In the configuration I have .pl listed under extensions which is Associate
>> with c:\Perl\Bin\Perl.exe "%s" %s and the verbs are listed as GET, HEAD,
>> POST the boxes are checked for both Script Engine and Verify that file
>exists.
>> (This is inserted by the ActivePerl installation process.)
>>
>> Even though we ?allow? the extension in the IIS under 'WebService
>Extensions'.
>>
>> Under execute permissions I have Scripts and Executables
>>
>> Under the Directory security tab in the Authentication and access control
>> properties I have the Enable anonymous access checked and I am using
the
>> IUSR_ account and correct password.
>>
>> It seems to be a configuration problem, because the script works perfectly
>> in the command line.
>>
>> I hope someone can help me
>> R.
>>
>>
>>
>> _______________________________________________
>> ActivePerl mailing list
>> ActivePerl@listserv.ActiveState.com
>> To unsubscribe: http://listserv.ActiveState.com/mailman/mysubs
>>
>>
>
>_______________________________________________
>ActivePerl mailing list
>ActivePerl@listserv.ActiveState.com
>To unsubscribe: http://listserv.ActiveState.com/mailman/mysubs



_______________________________________________
ActivePerl mailing list
ActivePerl@listserv.ActiveState.com
To unsubscribe: http://listserv.ActiveState.com/mailman/mysubs

Report this message

#6: Re: AW: Re: Help - CGI Error on IIS6

Posted on 2004-10-05 14:01:13 by David le Blanc

Ok, I'm assuming a level of sarcasm in this request...

How about this:

You print ....
> print "Content-Type: text/html\n";
> $level = "";
> undef %YET_DONE;

yop=me suggested :
> >When i have this problem, is becuase my script
> >dont sends the
> >print "Content-type: text/html\n\n";
> >first line.
> >Mybe there is the problem.
> >

Count the number of newlines dude. There should be two after the
Content-Type line as yop-me pointed out.

Cheers.
_______________________________________________
ActivePerl mailing list
ActivePerl@listserv.ActiveState.com
To unsubscribe: http://listserv.ActiveState.com/mailman/mysubs

Report this message

#7: Re: AW: Re: Help - CGI Error on IIS6

Posted on 2004-10-05 14:20:31 by Craig Cardimon

This reminds of a script I was trying to fix as a novice programmer in
the early 1990s. I rendered the script completely inoperable by
accidentally removing one of the two required newlines. It took me all
day to find that mistake. But as my manager back then said, "If you're
not breaking things, you're not learning."


> Count the number of newlines...There should be two after the
> Content-Type line...
>

-- Craig
_______________________________________________
ActivePerl mailing list
ActivePerl@listserv.ActiveState.com
To unsubscribe: http://listserv.ActiveState.com/mailman/mysubs

Report this message

#8: Re: AW: Re: Help - CGI Error on IIS6

Posted on 2004-10-05 14:32:18 by David le Blanc

Oh, how many times I prayed for 'cvs diff' before I knew it existed...
back as a novice programmer in the 1980's :-) :-)


On Tue, 05 Oct 2004 08:20:31 -0400, Craig Cardimon
wrote:
> This reminds of a script I was trying to fix as a novice programmer in
> the early 1990s. I rendered the script completely inoperable by
> accidentally removing one of the two required newlines. It took me all
> day to find that mistake. But as my manager back then said, "If you're
> not breaking things, you're not learning."
>
> > Count the number of newlines...There should be two after the
> > Content-Type line...
> >
>
> -- Craig
>
_______________________________________________
ActivePerl mailing list
ActivePerl@listserv.ActiveState.com
To unsubscribe: http://listserv.ActiveState.com/mailman/mysubs

Report this message

#9: Re: Re: Help - CGI Error on IIS6

Posted on 2004-10-05 15:23:21 by active

print "Content-Type: text/html\n";

here it is ... you must have 2 "\n"
line breaks.

print "Content-Type: text/html\n\n";

try it, and tell me.

----- Original Message -----
From:
To: "yop=me"
Cc:
Sent: Tuesday, October 05, 2004 4:10 AM
Subject: AW: Re: Help - CGI Error on IIS6


Hello yop-me,

First of all thank you very for your help. Following my Code. Do you know
where the fault is?

#!/usr/bin/perl

if ($0 =~ /(.*)\/[^\/]*$/) { push (@INC, "$1"); }
if ($0 =~ /(.*)\\[^\\]*$/) { push (@INC, "$1"); }
use site_lowlevel;
}
use site_lib;
use site_dlib;
use site_config;
use site_iolib;
use File::Find;
use site_form_lib;
use site_createlib;

%META_META = ();
@search_fields = ();
$Block_Count = 0; # A 'Block' is until the next CLEARLIST so each READDIR
only
$TIME = time; # CAPS means current time! c.k.

&active_finddate ($TIME);
$YEAR = $year;
$FULLYEAR = $fullyear;
$MON = $mon;
$MONAT = $monat;
$MDAY = $mday;
$DAYOFWEEK = $dayofweek;
$SEC = $sec;
$HOUR = $hour;
$MIN = $min;

$savepage_string = ""; # if you want to make
$taker_count = -1;

$basepath = "$SYSTEM_CONF{'DOCUMENT-ROOT'}";
$path = "$SYSTEM_CONF{'SITE-DIR'}";

%FORM = DecodeFormData (); # formulare auswerten

@cookie_fields = split (/\,/, $ENV{'HTTP_COOKIE'});
&split_cookie_fields; # Cookies auswerten
$checkfile = "indigo.htms"; # do not display this file

print "Content-Type: text/html\n";
$level = "";
undef %YET_DONE;
.....

Sebastian



>-- Originalnachricht --
>From: "yop=me"
>To:
>Date: Mon, 4 Oct 2004 08:41:43 -0400
>Subject: Re: Help - CGI Error on IIS6
>
>
>When i have this problem, is becuase my script
>dont sends the
>print "Content-type: text/html\n\n";
>first line.
>Mybe there is the problem.
>
>
>
>----- Original Message -----
>From:
>To:
>Sent: Monday, October 04, 2004 7:49 AM
>Subject: Help - CGI Error on IIS6
>
>
>> Hi all,
>>
>> I've searched in Google, Google groups and the ASPN Mailing List and
have
>> been looking for answers for days to get my cgi scripts to work in IIS6.
>> When I try to load a .pl file in my web browser, I get the following
>error:
>>
>> CGI Error
>> The specified CGI application misbehaved by not returning a complete
set
>> of HTTP headers.
>>
>> We're running a Windows 2003 Standard edition server with IIS6 and
>installed
>> ActivePerl 5.8.4.810 via the MSI with following settings:
>>
>> In the configuration I have .pl listed under extensions which is
Associate
>> with c:\Perl\Bin\Perl.exe "%s" %s and the verbs are listed as GET, HEAD,
>> POST the boxes are checked for both Script Engine and Verify that file
>exists.
>> (This is inserted by the ActivePerl installation process.)
>>
>> Even though we ?allow? the extension in the IIS under 'WebService
>Extensions'.
>>
>> Under execute permissions I have Scripts and Executables
>>
>> Under the Directory security tab in the Authentication and access control
>> properties I have the Enable anonymous access checked and I am using
the
>> IUSR_ account and correct password.
>>
>> It seems to be a configuration problem, because the script works
perfectly
>> in the command line.
>>
>> I hope someone can help me
>> R.
>>
>>
>>
>> _______________________________________________
>> ActivePerl mailing list
>> ActivePerl@listserv.ActiveState.com
>> To unsubscribe: http://listserv.ActiveState.com/mailman/mysubs
>>
>>
>
>_______________________________________________
>ActivePerl mailing list
>ActivePerl@listserv.ActiveState.com
>To unsubscribe: http://listserv.ActiveState.com/mailman/mysubs




_______________________________________________
ActivePerl mailing list
ActivePerl@listserv.ActiveState.com
To unsubscribe: http://listserv.ActiveState.com/mailman/mysubs

Report this message

#10: Re: AW: Re: Help - CGI Error on IIS6

Posted on 2004-10-05 15:25:37 by active

si no la caga, no aprende ... in spanish.

----- Original Message -----
From: "Craig Cardimon"
To: "David le Blanc"
Cc:
Sent: Tuesday, October 05, 2004 8:20 AM
Subject: Re: AW: Re: Help - CGI Error on IIS6


> This reminds of a script I was trying to fix as a novice programmer in
> the early 1990s. I rendered the script completely inoperable by
> accidentally removing one of the two required newlines. It took me all
> day to find that mistake. But as my manager back then said, "If you're
> not breaking things, you're not learning."
>
>
> > Count the number of newlines...There should be two after the
> > Content-Type line...
> >
>
> -- Craig
> _______________________________________________
> ActivePerl mailing list
> ActivePerl@listserv.ActiveState.com
> To unsubscribe: http://listserv.ActiveState.com/mailman/mysubs
>
>
_______________________________________________
ActivePerl mailing list
ActivePerl@listserv.ActiveState.com
To unsubscribe: http://listserv.ActiveState.com/mailman/mysubs

Report this message

#11: RE: Re: Help - CGI Error on IIS6

Posted on 2004-10-05 15:53:56 by cclarkson

romeo@pop.agri.ch wrote:

Please don't top post.

: First of all thank you very for your help. Following my
: Code. Do you know where the fault is?

You just had to ask that, didn't you?


: #!/usr/bin/perl
:
: if ($0 =~ /(.*)\/[^\/]*$/) { push (@INC, "$1"); }
: if ($0 =~ /(.*)\\[^\\]*$/) { push (@INC, "$1"); }

Statement modifiers tend to be easier to read. Don't
quote variables.

push @INC, $1 if $0 =~ /(.*)\/[^\/]*$/;
push @INC, $1 if $0 =~ /(.*)\\[^\\]*$/;

Are you sure you don't want to 'unshift' those?

Shouldn't you be checking for trailing duplicate entries
in @INC? Look at lib.pm.


: use site_lowlevel;

Why use an eight space indent for the 'if' statements
and switch to a two space indent for the 'use' statement.
Indent code blocks uniformly. Be consistent.


: }

Either this isn't the complete code or that closing
brace shouldn't be there.


: use site_lib;
: use site_dlib;
: use site_config;
: use site_iolib;
: use File::Find;
: use site_form_lib;
: use site_createlib;

Always use strict and warnings.

use strict;
use warnings;


: %META_META = ();
: @search_fields = ();

Don't use ALL CAPS for variables without a stated reason.
Don't declare variables before they are used. Declare them
just before or on their first use.


: $Block_Count = 0; # A 'Block' is until the next
: # CLEARLIST so each READDIR only
: $TIME = time; # CAPS means current time! c.k.

Avoid end comments. Especially on scripts sent via email.
They often wrap in the messages and they look ugly. Some of
your variables use underscores to separate words. This one
uses mixed case along with underscores. Other variable names
do not follow this pattern. Find one style and stick to it.
Be consistent. Read perlstyle.

# A 'Block' is until the next CLEARLIST so each READDIR only
my $block_count = 0;

The comment doesn't make sense in this context. What is a
CLEARLIST? and what READDIR is being referred to? Comments
are meant to relieve confusion, not to aid it.


my $TIME = time(); # CAPS means current time! c.k.

That is not a good reason to use ALL CAPS. Why explain
in the comment that $TIME is the current time? Use this --
no explanation needed.

my $current_time = time();


: &active_finddate ($TIME);

Read perlsub. Don't call subroutines using the & prefix.
Why separate the first word in the subroutine name and not
the second? Be consistent.

my $current_time = time();
active_find_date( $current_time );

Or just:

active_find_date( time() );


: $YEAR = $year;
: $FULLYEAR = $fullyear;

To be consistent that should be $FULL_YEAR and
$full_year.


: $MON = $mon;
: $MONAT = $monat;

What is a "monat"? Why not use descriptive words?


: $MDAY = $mday;
: $DAYOFWEEK = $dayofweek;

$DAY_OF_WEEK and $day_of_week;


: $SEC = $sec;

$seconds


: $HOUR = $hour;
: $MIN = $min;

$minutes

The lowercase variables have not been defined. We have
to assume that they were defined in active_find_date(), but
a good programmer would have then passed those variables
back (read perlsub). Here we use a hash slice to do the
same thing, but now we know where the values came from.

my %current;
@current{ qw(
two_digit_year
four_digit_year
month
monat
day
day_of_week
seconds
hour
minutes ) } = active_find_date( time() );

We can use $current{two_digit_year} instead of
$year. No comments needed. Read perlfunc 'return'.


: $savepage_string = ""; # if you want to make

The comment isn't helping. There are three words
in the variable name.

my $save_page_string = '';


: $taker_count = -1;
:
: $basepath = "$SYSTEM_CONF{'DOCUMENT-ROOT'}";
: $path = "$SYSTEM_CONF{'SITE-DIR'}";

Don't quote variables.

my $base_path = $SYSTEM_CONF{DOCUMENT-ROOT};
my $path = $SYSTEM_CONF{SITE-DIR};


: %FORM = DecodeFormData (); # formulare auswerten

Use CGI.pm to decode form data. Avoid using a hash to
hold field values. Here we have yet another naming convention
(mixed case). Choose one style. Be consistent.


: @cookie_fields = split (/\,/, $ENV{'HTTP_COOKIE'});
: &split_cookie_fields; # Cookies auswerten

Use CGI.pm (or a cookie module) for cookies.


: $checkfile = "indigo.htms"; # do not display this file

How does the comment relate to the statement?

my $check_file = 'indigo.htms';


: print "Content-Type: text/html\n";

As others have mentioned.

print "Content-Type: text/html\n\n";

Or:

use CGI 'header';
print header();


: $level = "";
: undef %YET_DONE;

You can't undef a hash that hasn't been defined anywhere.
If it was defined in a subroutine, it should remain scoped to
that subroutine.


HTH,

Charles K. Clarkson
--
Mobile Homes Specialist
254 968-8328





_______________________________________________
ActivePerl mailing list
ActivePerl@listserv.ActiveState.com
To unsubscribe: http://listserv.ActiveState.com/mailman/mysubs

Report this message