Bookmarks

Yahoo Gmail Google Facebook Delicious Twitter Reddit Stumpleupon Myspace Digg

Search queries

www.xxx.con, linux raid 10 near far offset comparison, xxxCons.jsp, w2ksp4 download, linux mdadm use spare drive, www.xxxcon, wwwxxxx.ocB, www...xxxcon, wwwxxxxcoN, Wwwxxx.con

Links

XODOX
Impressum

#1: .htaccess - how to make reference to multiple AuthUserFile

Posted on 2002-08-05 10:25:09 by GEOK TING TAN

I am running Apache 1.3.26 on Solaris 2.8. I am using .htaccess file to =
authenticate users when they access the home pages. Different password =
files are created to allow userID and password adminstration by different =
personnel.

I have created a .htaccess file under a directory :

AuthUserFile /opt/httpd/passwd
AuthUserFile /opt/httpd/passwd2
AuthName "MEMBER ONLINE SERVICES"
AuthType Basic
<Limit GET POST>
require valid-user
</limit>

The intention is to allow users to access all the files under the =
directory when users exist in either /opt/httpd/passwd or /opt/httpd/passwd=
2. The outcome was that if userA exist in file "passwd" and not =
"passwd2", the userA would encounter authorisation error. However, if =
userA exist in passwd2, the userA has no authorisation problem.

How do I change the .htaccess file to achieve what I want or is there any =
workaround?

Thank you.

Report this message

#2: RE: .htaccess - how to make reference to multiple AuthUserFile

Posted on 2002-08-05 10:38:42 by Boyle Owen

>From: GEOK TING TAN [mailto:TAN_GT@klse.com.my]
>
>I am running Apache 1.3.26 on Solaris 2.8. I am using=20
>.htaccess file to authenticate users when they access the home=20
>pages. Different password files are created to allow userID=20
>and password adminstration by different personnel.
>
>I have created a .htaccess file under a directory :
>
>AuthUserFile /opt/httpd/passwd
>AuthUserFile /opt/httpd/passwd2
>AuthName "MEMBER ONLINE SERVICES"
>AuthType Basic
><Limit GET POST>
>require valid-user
></limit>
>
>The intention is to allow users to access all the files under=20
>the directory when users exist in either /opt/httpd/passwd or=20
>/opt/httpd/passwd2. The outcome was that if userA exist in=20
>file "passwd" and not "passwd2", the userA would encounter=20
>authorisation error. However, if userA exist in passwd2, the=20
>userA has no authorisation problem.

This behaviour is what I would expect. When faced with directive =
overloading like this, apache usually takes the last directive, so =
"AuthUserFile passwd2" overwrites "AuthUserFile passwd".

I don't think there is a way to do this in apache, so I would recommend =
a workaround in unix, e.g. a root crontab entry like:

* * * * * cd /opt/httpd; cat passwd2 passwd > combined_passwd

will concatenate the two files every minute to make a combined file. =
Then change the directive to:

AuthUserFile /opt/httpd/combined_passwd

Rgds,
Owen Boyle

PS I would remove <Limit GET POST> - it is unnecessary...

Report this message

#3: Log rotation

Posted on 2002-08-05 19:39:07 by Paul English

I set up apache 2.0.35 with a plain config file (no log rotation
directives), and my log files are getting
automatically rotated. It appears to be based on their size, since there
is no consistency in the dates. They are all getting rotated at approx
4.3-4.4 megabytes. Why is that? Can I stop it from happening?

I need to make my logs only rotate when I tell them to, that is - once per
month, but at the moment they are getting big enough that apache is
rotating them more often.

Here's the line I'm using to log:
CustomLog logs/access_log common

Any help appreciated,
Paul

Report this message

#4: RE: setting up .biz and .co.uk

Posted on 2002-08-05 20:36:52 by Sebastian Wolfgarten

Hi,

it has nothing to do with
apache but post your named zones!
Maybe you send the files to me
using personal mail...

bye,
sebastian

Report this message

#5: setting up .biz and .co.uk

Posted on 2002-08-05 20:38:57 by Soheil Shaghaghi

Hi everyone,
I am running Apache 1.3.6, and live in the U.S.
Is there anyway to setup a .biz, or a .co.uk on the servers here?
I keep trying to set these in named, but named just doesn't see them!

Is there anything special I need to do?

Thanks,
Soheil

Report this message

#6: Re: Log rotation

Posted on 2002-08-05 22:27:36 by Lewis Watson

----- Original Message -----
From: "Paul English" <tallpaul@speakeasy.org>
To: <users@httpd.apache.org>
Sent: Monday, August 05, 2002 12:39 PM
Subject: Log rotation


>
> I set up apache 2.0.35 with a plain config file (no log rotation
> directives), and my log files are getting
> automatically rotated. It appears to be based on their size, since there
> is no consistency in the dates. They are all getting rotated at approx
> 4.3-4.4 megabytes. Why is that? Can I stop it from happening?
>
> I need to make my logs only rotate when I tell them to, that is - once per
> month, but at the moment they are getting big enough that apache is
> rotating them more often.
>
> Here's the line I'm using to log:
> CustomLog logs/access_log common
>
> Any help appreciated,
> Paul
>

What's is in your /etc/logrotate.d folder?

Lewis

Report this message