Bookmarks

Yahoo Gmail Google Facebook Delicious Twitter Reddit Stumpleupon Myspace Digg

Search queries

php save mails as eml, WWWXXXAPC, sqlexpress database file auto-creation error, sqlexpress database file auto-creation error, dbf2mysql parameter, wwwxxxAPC, How to unsubscrube from dategen spam, docmd.close 2585, WWWXXXDOCO, nu vot

Links

XODOX
Impressum

#1: cannot do chmod

Posted on 2003-05-28 15:26:11 by Earl

Good day...

I need help on this... I mounted my windows partition on
the /mnt/win directory. The strange thing is that there is
no execute permission for the group and others category
on the /mnt/win directory. So I tried to `chmod -v go+x /mnt/win'
and it printed out that the chmod was successful. BUT when
I do an `ls -l /mnt' the file permissions were unchanged. This is the first
time I encountered this problem and I really have no idea why
this is happening.

The reason why I want to place an execute permission on the /mnt/win
directory is that I want other non-root users to access the windows
partition.

Does this have to do with the mount options? If it does, I placed the
contents of my fstab below in case you guys want to find anything wrong
with it. I don't know anything else that might cause this problem.

[these are the contents of my fstab]

/dev/hda5 swap swap defaults 0 0
/dev/hda7 / ext3 defaults 1 1
/dev/hda6 /home ext3 defaults 1 2
/dev/hda3 /mnt/win vfat defaults 1 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0


=================================
There are seven words in this sentence.
=================================


-
To unsubscribe from this list: send the line "unsubscribe linux-admin" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html

Report this message

#2: Re: cannot do chmod

Posted on 2003-05-29 03:35:42 by Andrew Lister

Add a umask=0 to the mount options ie:

/dev/hda3 /mnt/win vfat defaults,umask=0 0 0

Andrew





elapus@ntsp.nec.co.jp
Sent by: To: linux-admin@vger.kernel.org
linux-admin-owner@vger cc:
.kernel.org Subject: cannot do chmod


28/05/2003 23:26






Good day...

I need help on this... I mounted my windows partition on
the /mnt/win directory. The strange thing is that there is
no execute permission for the group and others category
on the /mnt/win directory. So I tried to `chmod -v go+x /mnt/win'
and it printed out that the chmod was successful. BUT when
I do an `ls -l /mnt' the file permissions were unchanged. This is the first
time I encountered this problem and I really have no idea why
this is happening.

The reason why I want to place an execute permission on the /mnt/win
directory is that I want other non-root users to access the windows
partition.

Does this have to do with the mount options? If it does, I placed the
contents of my fstab below in case you guys want to find anything wrong
with it. I don't know anything else that might cause this problem.

[these are the contents of my fstab]

/dev/hda5 swap swap defaults 0 0
/dev/hda7 / ext3 defaults 1 1
/dev/hda6 /home ext3 defaults 1 2
/dev/hda3 /mnt/win vfat defaults 1 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0


=================================
There are seven words in this sentence.
=================================


-
To unsubscribe from this list: send the line "unsubscribe linux-admin" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html





--

This e-mail may contain confidential and/or privileged information. If you are not the intended recipient (or have received this e-mail in error) please notify the sender immediately and destroy this e-mail. Any unauthorized copying, disclosure or distribution of the material in this e-mail is strictly forbidden.


-
To unsubscribe from this list: send the line "unsubscribe linux-admin" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html

Report this message

#3: Re: cannot do chmod

Posted on 2003-05-29 03:42:02 by jbrown1050

On Wed, May 28, 2003 at 09:26:11PM +0800, Earl R. Lapus wrote:
> Good day...
>
> I need help on this... I mounted my windows partition on
> the /mnt/win directory. The strange thing is that there is
> no execute permission for the group and others category
> on the /mnt/win directory. So I tried to `chmod -v go+x /mnt/win'
> and it printed out that the chmod was successful. BUT when
> I do an `ls -l /mnt' the file permissions were unchanged. This is the first
> time I encountered this problem and I really have no idea why
> this is happening.
>
> The reason why I want to place an execute permission on the /mnt/win
> directory is that I want other non-root users to access the windows
> partition.
>
> Does this have to do with the mount options? If it does, I placed the
> contents of my fstab below in case you guys want to find anything wrong
> with it. I don't know anything else that might cause this problem.
>
> [these are the contents of my fstab]
>
> /dev/hda5 swap swap defaults 0 0
> /dev/hda7 / ext3 defaults 1 1
> /dev/hda6 /home ext3 defaults 1 2
> /dev/hda3 /mnt/win vfat defaults 1 0

Try this line out:

/dev/hda3 /mnt/win vfat defaults,umask=000,mode=777 1 0

Set 'mode=' to whatever permissions you want the files to be.

> /dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
> /dev/fd0 /mnt/floppy auto noauto,owner 0 0
> devpts /dev/pts devpts gid=5,mode=620 0 0
> proc /proc proc defaults 0 0
>
>
> =================================
> There are seven words in this sentence.
> =================================
>
>
> -
> To unsubscribe from this list: send the line "unsubscribe linux-admin" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at http://vger.kernel.org/majordomo-info.html

--
/"\ ASCII ribbon | http://www.geocities.com/jbrown1050/
\ / campain against | Linux User:190064
X HTML in e-mail and | Linux Machine:84163
/*\ news, and unneeded MIME |
------------------------------------------------------------ ----------
You too can spend five years in prison; just distribute this program
once US Senator Hollings's CBDTPA bill is passed into law:
perl -e 'while(<>) { print;}'


-
To unsubscribe from this list: send the line "unsubscribe linux-admin" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html

Report this message