Bookmarks

Yahoo Gmail Google Facebook Delicious Twitter Reddit Stumpleupon Myspace Digg

Search queries

Wwwwxxx reemine, WWWXXX.VCBA, WWWXXX.VCBA, TheboL.wwwxxxxx, WWWXXXAPC , wwwxxn.xsss, wwwxxxapc, WWWXXX.VCBA, wwwxxx vba, wwwxxxdoco

Links

XODOX
Impressum

#1: Apache Password authentication issues

Posted on 2008-03-27 20:52:53 by Sailesh Krishnamurthy

------=_Part_26815_8714427.1206647573281
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

Hi,


We tried setting up password authentication on one of the directories in our
apache virtualhost using a .htaccess file . we now notice that
the password authentication is working only for some users and not others.
Has anyone else noticed this. Ami I missing something here.
The directory and .htacess configs are as below:

47 <Directory /ab/web/virthosts/abportal/prod/abcd>
48 AllowOverride ALL
49 Options Indexes FollowSymLinks Includes ExecCGI
50 Order allow,deny
51 Allow from all
52 AddType text/plain .txt
53 DefaultType text/plain
54 AddHandler cgi-script .cgi .pl
55 </Directory>

..htacess:

deny from all
AuthType Basic
AuthName "Password Required"
AuthUserFile /ab/web/virthosts/abortal/prod/abcd/passwd
AuthGroupFile /ab/web/virthosts/bbiportal/prod/abcd/groups
Require group abcd
Require user efgh
satisfy any

------=_Part_26815_8714427.1206647573281
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

Hi,<br><br><br>We tried setting up password authentication on one of the directories in our apache virtualhost using a .htaccess file . we now notice that <br>the password authentication is working only for some users and not others. Has anyone else noticed this. Ami I missing something here.<br>
The directory and .htacess configs are as below:<br><br>&nbsp;&nbsp;&nbsp; 47&nbsp;&nbsp; &lt;Directory /ab/web/virthosts/abportal/prod/abcd&gt;<br>&nbsp;&nbsp;&nbsp; 48&nbsp;&nbsp;&nbsp;&nbsp; AllowOverride ALL<br>&nbsp;&nbsp;&nbsp; 49&nbsp;&nbsp;&nbsp;&nbsp; Options Indexes FollowSymLinks Includes ExecCGI<br>&nbsp;&nbsp;&nbsp; 50&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Order allow,deny<br>
&nbsp;&nbsp;&nbsp; 51&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Allow from all<br>&nbsp;&nbsp;&nbsp; 52&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; AddType text/plain .txt<br>&nbsp;&nbsp;&nbsp; 53&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; DefaultType text/plain<br>&nbsp;&nbsp;&nbsp; 54&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; AddHandler cgi-script .cgi .pl<br>&nbsp;&nbsp;&nbsp; 55&nbsp; &lt;/Directory&gt;<br><br>.htacess:<br><br>deny from all<br>
AuthType Basic<br>AuthName &quot;Password Required&quot;<br>AuthUserFile /ab/web/virthosts/abortal/prod/abcd/passwd<br>AuthGroupFile /ab/web/virthosts/bbiportal/prod/abcd/groups<br>Require group abcd<br>Require user efgh<br>
satisfy any<br>

------=_Part_26815_8714427.1206647573281--

Report this message

#2: Fwd: Apache Password authentication issues

Posted on 2008-03-28 14:47:53 by Sailesh Krishnamurthy

------=_Part_29897_1242447.1206712073464
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

any luck with this ?

---------- Forwarded message ----------
From: Sailesh Krishnamurthy <sailesh.krish@gmail.com>
Date: Thu, Mar 27, 2008 at 3:52 PM
Subject: Apache Password authentication issues
To: users@httpd.apache.org


Hi,


We tried setting up password authentication on one of the directories in our
apache virtualhost using a .htaccess file . we now notice that
the password authentication is working only for some users and not others.
Has anyone else noticed this. Ami I missing something here.
The directory and .htacess configs are as below:

47 <Directory /ab/web/virthosts/abportal/prod/abcd>
48 AllowOverride ALL
49 Options Indexes FollowSymLinks Includes ExecCGI
50 Order allow,deny
51 Allow from all
52 AddType text/plain .txt
53 DefaultType text/plain
54 AddHandler cgi-script .cgi .pl
55 </Directory>

..htacess:

deny from all
AuthType Basic
AuthName "Password Required"
AuthUserFile /ab/web/virthosts/abortal/prod/abcd/passwd
AuthGroupFile /ab/web/virthosts/bbiportal/prod/abcd/groups
Require group abcd
Require user efgh
satisfy any

------=_Part_29897_1242447.1206712073464
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

any luck with this&nbsp; ?<br><br><div class="gmail_quote">---------- Forwarded message ----------<br>From: <b class="gmail_sendername">Sailesh Krishnamurthy</b> &lt;<a href="mailto:sailesh.krish@gmail.com">sailesh.krish@gmail.com</a>&gt;<br>
Date: Thu, Mar 27, 2008 at 3:52 PM<br>Subject: Apache Password authentication issues<br>To: <a href="mailto:users@httpd.apache.org">users@httpd.apache.org</a><br><br><br>Hi,<br><br><br>We tried setting up password authentication on one of the directories in our apache virtualhost using a .htaccess file . we now notice that <br>
the password authentication is working only for some users and not others. Has anyone else noticed this. Ami I missing something here.<br>
The directory and .htacess configs are as below:<br><br>&nbsp;&nbsp;&nbsp; 47&nbsp;&nbsp; &lt;Directory /ab/web/virthosts/abportal/prod/abcd&gt;<br>&nbsp;&nbsp;&nbsp; 48&nbsp;&nbsp;&nbsp;&nbsp; AllowOverride ALL<br>&nbsp;&nbsp;&nbsp; 49&nbsp;&nbsp;&nbsp;&nbsp; Options Indexes FollowSymLinks Includes ExecCGI<br>&nbsp;&nbsp;&nbsp; 50&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Order allow,deny<br>

&nbsp;&nbsp;&nbsp; 51&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Allow from all<br>&nbsp;&nbsp;&nbsp; 52&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; AddType text/plain .txt<br>&nbsp;&nbsp;&nbsp; 53&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; DefaultType text/plain<br>&nbsp;&nbsp;&nbsp; 54&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; AddHandler cgi-script .cgi .pl<br>&nbsp;&nbsp;&nbsp; 55&nbsp; &lt;/Directory&gt;<br><br>.htacess:<br><br>deny from all<br>

AuthType Basic<br>AuthName &quot;Password Required&quot;<br>AuthUserFile /ab/web/virthosts/abortal/prod/abcd/passwd<br>AuthGroupFile /ab/web/virthosts/bbiportal/prod/abcd/groups<br>Require group abcd<br>Require user efgh<br>

satisfy any<br>
</div><br>

------=_Part_29897_1242447.1206712073464--

Report this message

#3: Re: Apache Password authentication issues

Posted on 2008-03-28 21:23:31 by Eric Covener

On Thu, Mar 27, 2008 at 3:52 PM, Sailesh Krishnamurthy
<sailesh.krish@gmail.com> wrote:
> Hi,
>
>
> We tried setting up password authentication on one of the directories in our
> apache virtualhost using a .htaccess file . we now notice that
> the password authentication is working only for some users and not others.

Which ones?

From a thread this week:

Perhaps: http://httpd.apache.org/docs/2.2/mod/mod_authz_groupfile.htm l#authzgroupfileauthoritative

--
Eric Covener
covener@gmail.com

------------------------------------------------------------ ---------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
" from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

Report this message

#4: Re: Apache Password authentication issues

Posted on 2008-03-28 22:06:48 by Sailesh Krishnamurthy

------=_Part_32056_21084585.1206738408257
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

actually, I found out what the problem was? now wondering how to rectify
it.

see our apache web server also uses a custom authentication module and the
earlier LoadModule config overrides the AllowOverride ALL directive that is
set in the Directory entry.

Any ideas how to get around this?

On Fri, Mar 28, 2008 at 4:23 PM, Eric Covener <covener@gmail.com> wrote:

> On Thu, Mar 27, 2008 at 3:52 PM, Sailesh Krishnamurthy
> <sailesh.krish@gmail.com> wrote:
> > Hi,
> >
> >
> > We tried setting up password authentication on one of the directories in
> our
> > apache virtualhost using a .htaccess file . we now notice that
> > the password authentication is working only for some users and not
> others.
>
> Which ones?
>
> From a thread this week:
>
> Perhaps:
> http://httpd.apache.org/docs/2.2/mod/mod_authz_groupfile.htm l#authzgroupfileauthoritative
>
> --
> Eric Covener
> covener@gmail.com
>
> ------------------------------------------------------------ ---------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> " from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>

------=_Part_32056_21084585.1206738408257
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

actually,&nbsp; I found out what the problem was? now wondering how to rectify it.<br><br>see our apache web server also uses a custom authentication module and the earlier LoadModule config overrides the AllowOverride ALL directive that is set&nbsp; in the Directory entry. <br>
<br>Any ideas how to get around this?<br><br><div class="gmail_quote">On Fri, Mar 28, 2008 at 4:23 PM, Eric Covener &lt;<a href="mailto:covener@gmail.com">covener@gmail.com</a>&gt; wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<div class="Ih2E3d">On Thu, Mar 27, 2008 at 3:52 PM, Sailesh Krishnamurthy<br>
&lt;<a href="mailto:sailesh.krish@gmail.com">sailesh.krish@gmail.com</a>&gt; wrote:<br>
&gt; Hi,<br>
&gt;<br>
&gt;<br>
&gt; We tried setting up password authentication on one of the directories in our<br>
&gt; apache virtualhost using a .htaccess file . we now notice that<br>
&gt; the password authentication is working only for some users and not others.<br>
<br>
</div>Which ones?<br>
<br>
From a thread this week:<br>
<br>
Perhaps: <a href="http://httpd.apache.org/docs/2.2/mod/mod_authz_groupfile.html#authzgroupfileauthoritative" target="_blank"> http://httpd.apache.org/docs/2.2/mod/mod_authz_groupfile.htm l#authzgroupfileauthoritative</a><br>

<br>
--<br>
Eric Covener<br>
<a href="mailto:covener@gmail.com">covener@gmail.com</a><br>
<br>
------------------------------------------------------------ ---------<br>
The official User-To-User support forum of the Apache HTTP Server Project.<br>
See &lt;URL:<a href="http://httpd.apache.org/userslist.html" target="_blank">http://httpd.apache.org/userslist.html</a>&gt; for more info.<br>
To unsubscribe, e-mail: <a href="mailto:users-unsubscribe@httpd.apache.org">users-unsubscribe@httpd.apache.org</a><br>
&nbsp; &quot; &nbsp; from the digest: <a href="mailto:users-digest-unsubscribe@httpd.apache.org">users-digest-unsubscribe@httpd.apache.org</a><br>
For additional commands, e-mail: <a href="mailto:users-help@httpd.apache.org">users-help@httpd.apache.org</a><br>
<br>
</blockquote></div><br>

------=_Part_32056_21084585.1206738408257--

Report this message

#5: Fwd: Apache Password authentication issues

Posted on 2008-03-31 17:49:21 by Sailesh Krishnamurthy

------=_Part_3622_13244865.1206978561191
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

any ideas, how to force apache 1.3 to use the .htaccess file and not use the
authentication module?

---------- Forwarded message ----------
From: Sailesh Krishnamurthy <sailesh.krish@gmail.com>
Date: Fri, Mar 28, 2008 at 5:06 PM
Subject: Re: [users@httpd] Apache Password authentication issues
To: users@httpd.apache.org


actually, I found out what the problem was? now wondering how to rectify
it.

see our apache web server also uses a custom authentication module and the
earlier LoadModule config overrides the AllowOverride ALL directive that is
set in the Directory entry.

Any ideas how to get around this?


On Fri, Mar 28, 2008 at 4:23 PM, Eric Covener <covener@gmail.com> wrote:

> On Thu, Mar 27, 2008 at 3:52 PM, Sailesh Krishnamurthy
> <sailesh.krish@gmail.com> wrote:
> > Hi,
> >
> >
> > We tried setting up password authentication on one of the directories in
> our
> > apache virtualhost using a .htaccess file . we now notice that
> > the password authentication is working only for some users and not
> others.
>
> Which ones?
>
> From a thread this week:
>
> Perhaps:
> http://httpd.apache.org/docs/2.2/mod/mod_authz_groupfile.htm l#authzgroupfileauthoritative
>
> --
> Eric Covener
> covener@gmail.com
>
> ------------------------------------------------------------ ---------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> " from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>

------=_Part_3622_13244865.1206978561191
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

any ideas, how to force apache 1.3 to use the .htaccess file and not use the authentication module?<br><br><div class="gmail_quote">---------- Forwarded message ----------<br>From: <b class="gmail_sendername">Sailesh Krishnamurthy</b> &lt;<a href="mailto:sailesh.krish@gmail.com">sailesh.krish@gmail.com</a>&gt;<br>
Date: Fri, Mar 28, 2008 at 5:06 PM<br>Subject: Re: [users@httpd] Apache Password authentication issues<br>To: <a href="mailto:users@httpd.apache.org">users@httpd.apache.org</a><br><br><br>actually,&nbsp; I found out what the problem was? now wondering how to rectify it.<br>
<br>see our apache web server also uses a custom authentication module and the earlier LoadModule config overrides the AllowOverride ALL directive that is set&nbsp; in the Directory entry. <br>
<br>Any ideas how to get around this?<div><div></div><div class="Wj3C7c"><br><br><div class="gmail_quote">On Fri, Mar 28, 2008 at 4:23 PM, Eric Covener &lt;<a href="mailto:covener@gmail.com" target="_blank">covener@gmail.com</a>&gt; wrote:<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<div>On Thu, Mar 27, 2008 at 3:52 PM, Sailesh Krishnamurthy<br>
&lt;<a href="mailto:sailesh.krish@gmail.com" target="_blank">sailesh.krish@gmail.com</a>&gt; wrote:<br>
&gt; Hi,<br>
&gt;<br>
&gt;<br>
&gt; We tried setting up password authentication on one of the directories in our<br>
&gt; apache virtualhost using a .htaccess file . we now notice that<br>
&gt; the password authentication is working only for some users and not others.<br>
<br>
</div>Which ones?<br>
<br>
From a thread this week:<br>
<br>
Perhaps: <a href="http://httpd.apache.org/docs/2.2/mod/mod_authz_groupfile.html#authzgroupfileauthoritative" target="_blank"> http://httpd.apache.org/docs/2.2/mod/mod_authz_groupfile.htm l#authzgroupfileauthoritative</a><br>


<br>
--<br>
Eric Covener<br>
<a href="mailto:covener@gmail.com" target="_blank">covener@gmail.com</a><br>
<br>
------------------------------------------------------------ ---------<br>
The official User-To-User support forum of the Apache HTTP Server Project.<br>
See &lt;URL:<a href="http://httpd.apache.org/userslist.html" target="_blank">http://httpd.apache.org/userslist.html</a>&gt; for more info.<br>
To unsubscribe, e-mail: <a href="mailto:users-unsubscribe@httpd.apache.org" target="_blank">users-unsubscribe@httpd.apache.org</a><br>
&nbsp; &quot; &nbsp; from the digest: <a href="mailto:users-digest-unsubscribe@httpd.apache.org" target="_blank">users-digest-unsubscribe@httpd.apache.org</a><br>
For additional commands, e-mail: <a href="mailto:users-help@httpd.apache.org" target="_blank">users-help@httpd.apache.org</a><br>
<br>
</blockquote></div><br>
</div></div></div><br>

------=_Part_3622_13244865.1206978561191--

Report this message