Bookmarks

Yahoo Gmail Google Facebook Delicious Twitter Reddit Stumpleupon Myspace Digg

Search queries

dbf2mysql parameter, WWWXXXAPC, wwwxxxAPC, How to unsubscrube from dategen spam, docmd.close 2585, WWWXXXDOCO, nu vot, dhcpd lease file "binding state", WWWXXXDOCO, how to setup procmail to process html2text

Links

XODOX
Impressum

#1: asp on IIS7

Posted on 2008-04-11 01:19:00 by jasonhartsoe

I'm running IIS7(2008 Server) and SQL both 64 bit. There's a simple client
side code...that just doesn't make any sense. Is there something in IIS7
that could possibly have some effect on including the file. The problem is:

<script src="myfiletoinclude.inc"></script>

it works fine on my 2000 and 2003 box....running IE8 emulating IE7. No
problems....but on the 08 box...it won't pull in the page. Is there a
setting or a place I can go to fix this? I'm clueless....

Thanks!

Report this message

#2: Re: asp on IIS7

Posted on 2008-04-11 08:25:39 by Anthony Jones

"Jason Hartsoe" <JasonHartsoe@discussions.microsoft.com> wrote in message
news:41E2B36C-CC3E-42A5-A815-58F75D5B9F96@microsoft.com...
> I'm running IIS7(2008 Server) and SQL both 64 bit. There's a simple
client
> side code...that just doesn't make any sense. Is there something in IIS7
> that could possibly have some effect on including the file. The problem
is:
>
> <script src="myfiletoinclude.inc"></script>
>
> it works fine on my 2000 and 2003 box....running IE8 emulating IE7. No
> problems....but on the 08 box...it won't pull in the page. Is there a
> setting or a place I can go to fix this? I'm clueless....
>


Change the .inc file extension to .js or .vbs which ever matches the
content.

A possible cause of the problem is the server not having a .inc in its
mimemap, without a catch all .* being present (which is not recommended) the
file won't be served.

Another possible cause is IE being more restrictive, it may not like
treating a .inc file that doesn't have a text/javascript or text/vbscript
content type as a script. Thats a guess I haven't played with IE8 yet.



--
Anthony Jones - MVP ASP/ASP.NET

Report this message

#3: Re: asp on IIS7

Posted on 2008-04-11 14:02:00 by jasonhartsoe

well i did try changing it to a js...but still ended up with nothing...it's a
weird thing. The exact same page served on two different machines...one
works, the other doesn't. IIS7 is still new to me...I wouldn't think it'd be
anything to do server side...rather than client side...

I'll keep looking.

Thanks Anthony!

"Anthony Jones" wrote:

> "Jason Hartsoe" <JasonHartsoe@discussions.microsoft.com> wrote in message
> news:41E2B36C-CC3E-42A5-A815-58F75D5B9F96@microsoft.com...
> > I'm running IIS7(2008 Server) and SQL both 64 bit. There's a simple
> client
> > side code...that just doesn't make any sense. Is there something in IIS7
> > that could possibly have some effect on including the file. The problem
> is:
> >
> > <script src="myfiletoinclude.inc"></script>
> >
> > it works fine on my 2000 and 2003 box....running IE8 emulating IE7. No
> > problems....but on the 08 box...it won't pull in the page. Is there a
> > setting or a place I can go to fix this? I'm clueless....
> >
>
>
> Change the .inc file extension to .js or .vbs which ever matches the
> content.
>
> A possible cause of the problem is the server not having a .inc in its
> mimemap, without a catch all .* being present (which is not recommended) the
> file won't be served.
>
> Another possible cause is IE being more restrictive, it may not like
> treating a .inc file that doesn't have a text/javascript or text/vbscript
> content type as a script. Thats a guess I haven't played with IE8 yet.
>
>
>
> --
> Anthony Jones - MVP ASP/ASP.NET
>
>
>

Report this message

#4: Re: asp on IIS7

Posted on 2008-04-11 14:16:04 by jasonhartsoe

I found the problem. IIS7 requires the MIME Type to be defined for all files
used. Currently the file was serving a 404...but with the added type it now
serves it correctly without any problems.

THanks again!

"Jason Hartsoe" wrote:

> well i did try changing it to a js...but still ended up with nothing...it's a
> weird thing. The exact same page served on two different machines...one
> works, the other doesn't. IIS7 is still new to me...I wouldn't think it'd be
> anything to do server side...rather than client side...
>
> I'll keep looking.
>
> Thanks Anthony!
>
> "Anthony Jones" wrote:
>
> > "Jason Hartsoe" <JasonHartsoe@discussions.microsoft.com> wrote in message
> > news:41E2B36C-CC3E-42A5-A815-58F75D5B9F96@microsoft.com...
> > > I'm running IIS7(2008 Server) and SQL both 64 bit. There's a simple
> > client
> > > side code...that just doesn't make any sense. Is there something in IIS7
> > > that could possibly have some effect on including the file. The problem
> > is:
> > >
> > > <script src="myfiletoinclude.inc"></script>
> > >
> > > it works fine on my 2000 and 2003 box....running IE8 emulating IE7. No
> > > problems....but on the 08 box...it won't pull in the page. Is there a
> > > setting or a place I can go to fix this? I'm clueless....
> > >
> >
> >
> > Change the .inc file extension to .js or .vbs which ever matches the
> > content.
> >
> > A possible cause of the problem is the server not having a .inc in its
> > mimemap, without a catch all .* being present (which is not recommended) the
> > file won't be served.
> >
> > Another possible cause is IE being more restrictive, it may not like
> > treating a .inc file that doesn't have a text/javascript or text/vbscript
> > content type as a script. Thats a guess I haven't played with IE8 yet.
> >
> >
> >
> > --
> > Anthony Jones - MVP ASP/ASP.NET
> >
> >
> >

Report this message

#5: Re: asp on IIS7

Posted on 2008-04-11 16:35:58 by Anthony Jones

"Jason Hartsoe" <JasonHartsoe@discussions.microsoft.com> wrote in message
news:E93F2EFA-AB2A-4BC0-A4B1-805A7CA96AB4@microsoft.com...
> I found the problem. IIS7 requires the MIME Type to be defined for all
files
> used. Currently the file was serving a 404...but with the added type it
now
> serves it correctly without any problems.
>


Strange thats true of IIS6 too. By default it has a .js mapping. Did your
IIS7 not have a .js mapping in the server mimetypes? Or could it be that
you had some mime types at the site level? This is a common problem since
from IIS point of view the mimemap is a single property. Hence assigning
something to the mimemap lower down masks the whole mimemap from the server
level in the metabase.

--
Anthony Jones - MVP ASP/ASP.NET

Report this message

#6: Re: asp on IIS7

Posted on 2008-04-11 16:36:02 by Dave Anderson

Jason Hartsoe wrote:
> I found the problem. IIS7 requires the MIME Type to be defined for
> all files used. Currently the file was serving a 404...but with the
> added type it now serves it correctly without any problems.

IIS6 has the same requirement.



--
Dave Anderson

Unsolicited commercial email will be read at a cost of $500 per message. Use
of this email address implies consent to these terms.

Report this message