Bookmarks

Yahoo Gmail Google Facebook Delicious Twitter Reddit Stumpleupon Myspace Digg

Search queries

phpmyadmin fehler rechte unerlaubte mischung, WWWXXXApc, lilo trying to map files from unnamed device 0x0000", Wwwxxxapc, CAM::PDF::Renderer::TextF Fragen, adodb.recordset error '800a0cc1', php save mails as eml, WWWXXXAPC, sqlexpress database file auto-creation error, sqlexpress database file auto-creation error

Links

XODOX
Impressum
Datenschutz

#1: building mod_perl-1.30 - mod_perl.h not getting installed?

Posted on 2010-05-27 21:30:37 by E R

Hello,

I'm building ancient versions of apache and mod_perl (with perl 5.8.9)
in the following way:

tar zxf apache_1.3.41.tar.gz
cd apache_1.3.41
../configure --prefix=/APACHE-PREFIX --enable-module=so
--enable-module=access (... more --enable-module) \
--disable-module=imap --disable-module=userdir --disable-rule=EXPAT
make
make install

cd ..
tar zxf mod_perl-1.30.tar.gz
perl Makefile.PL EVERYTHING=1 PREFIX=/PERL-PREFIX \
USE_APXS=1 \
WITH_APXS=/APACHE-PREFIX/bin/apxs
APACHE_SRC=../apache_1.3.41/src
make
make install

The problem is that include files like mod_perl.h are not getting
installed in the perl tree.

When I try to build libapreq-1.34 I'll get compilation errors like:

Request.xs:41:22: mod_perl.h: No such file or directory

What do I need to do to get the mod_perl include files installed?

Thanks,
ER

Report this message